EcoLink Tilt Sensors won't connect help


(Ladysman) #1

These things won’t connect at all to smartthings hub. Is there a trick to getting these to connect?? Known issue with the new app? Procedure to connect?

Thanks!


(Steve Ganz) #2

I just connected one today and had no problems. The instructions indicate that you need to place the controller into inclusion mode before inserting the battery.

So from the Dashboard, tap the + button at the bottom of the screen and then tap Connect New Device. While it is searching, insert the battery into the sensor. Shortly after LED light on the sensor goes out, you should see a success message in the app indicating that it has found a new device.


(JRR) #3

The app reports new device added but not of correct type" it then continues to search


(Billwitt27) #4

The Ecolink products are very finicky. I have two garage door sensors. The only way to get mine to connect the first time was to reboot the ST hub and THEN start the discovery process. I also have an Ecolink door sensor that I have never been able to pair with my hub.


(Dave) #5

The first three Z-Wave items that I tried to pair up with my ST hub are all Ecolink and I pulled my hair out for a couple of hours. This wasn’t mentioned in the OP so I don’t know if it applies here or not, but in my case I finally decided to view all events for the ST hub and there was my answer right in front of me. The ST hub was not the primary Z-Wave controller. I had it join an existing Z-Wave network in which my Vera Lite was the primary. I then set about excluding everything from the Vera, separated the two Z-Wave networks thereby making the ST hub it’s own autonomous Z-Wave network, and then all of the Ecolinks paired up immediately and without issue.


(Bryan) #6

This is what I get. And in the pairing dialog screen, the wrong image is shown - a Smartthings Multisensor. I wonder if there’s something as simple as the wrong device tied to that screen?


#7

I have the ecolink tilt sensor working, but the device type is the wrong thing–thus the icon is wrong. But the sensor still works.

First, if you have ever paired any of the ecolink sensors (including tilt) with any other system, you first need to unpair the device. This is done by going to the ide site from your computer to add a fake device and then from your phone unpairing the real device.

Here are the details to unpair a device that is paired to another system (also good for troubleshooting a device that is not working):

  1. Log into here: https://graph.api.smartthings.com
  2. My Devices
  3. New Device
  4. Fill in required fields. Pick a random name and pick a Device hexidecimal device ID that is not in use. ex: 1A. For type pick z-wave door/window sensor then select your location and hub. Click Create
  5. From the phone app, find the newly-created device under Things, click the gear in the top right of the device, click Preferences, and then remove.
  6. Then remove the battery and put it back in.
  7. It will tell you it either found the device to unpair or it unpaired an unrelated device. If it does that, then click Force Delete if the message is still there.

Here is how I got the tilt sensor to pair:

  1. In the phone app, click the plus sign to get into setup
  2. Click Connect New Device
  3. Remove the battery of the motion detector and put it back in
  4. It will autodetect, but the category may be incorrect (Z-wave Door/Window will make the tilt work even if the icon is incorrect)
  5. You can change it to z-wave door/window by using your computer to go to https://graph.api.smartthings.com
  6. Click My Devices
  7. Click on the device you just added
  8. Edit
  9. In the Type drop down, select Z-wave Door/Window Sensor

The icon will be wrong, but it will still detect an open or closed garage door. Ugh, I wish there was a clean fix for this…


#8

@vbandit

Thanks for posting these steps! I just added another Ecolink door/window sensor to my system. I tried 5 or 6 times earlier today to add this sensor but it just would not show up in ST. I followed your steps above and it worked on the next try.
I did not think these steps would work but they did!
Thanks


(Rodney) #9

This worked for me. Rebooting the ST hub, then trying the pairing process again.


(Eric Vanderslice) #10

Having problems here too. New out of box device. But what I am seeing is that the device is never detected or added at all to ST. I know you often have to edit Ecolink devices after pairing. But I can’t get it to pair. I tried just the generic remove from any system, but it wasn’t detected by my Aeon Z-stick that way either. Wondering if I just have a bad device?


#11

I had the exact same problem. I ordered two of them and couldn’t get them to sync at all. Once I unplugged my ST hub and reconnected it, I was able to add them. They never show up as the EcoLink smart sensors… but they work just fine.


(Andre B) #12

What ultimately worked for me was going to this link:
(https://graph-na02-useast1.api.smartthings.com)

Go to your hubs and scroll down about midway to View Utilities.

Under view View Utilities find Z-Wave Exclude. Get the device ready by removing the battery for at least 5 seconds. Click Z-Wave Exclude and then insert the battery. You will see the led flash.

Once thats done remove the battery again and pair the device normally. It will not recognize it as the correct device so go into your device panel ONLINE and set the sensor as a wave door/window sensor to have basic functionality.


(Derek W Beck) #13

And a key point here: make sure the cover is on the device sensor. I could not get this to work at all. Then I realized the cover has a prong of plastic that holds down the little switch. (The LED was on constantly until putting this cover on too.) Once I followed Anthem127’s steps and then put the cover on, it worked. Yes, online, I had to edit the device type to generic Zwave Door/Window Sensor as well. But seems to work now. Cheers all.