Ecolink Door/Window Sensor Will Not Pair


(kelly conner) #1

I am trying to connect a Ecolink Door/Window sensor and I am not having any luck. This is my first device that I am trying to connect to the SmartThings hub so I am not sure if I am missing something.

With the phone app searching for the sensor, I remove the battery from the sensor for more than 5 seconds, insert the battery and put the cover on. The light on the sensor is solid for a few seconds, then blinks slowly for a few seconds and then it goes out. When I move the magnet near the sensor it blinks slowly for a few seconds. According to the instructions it is not connected and I need to repeat the process. I have done this at least 25 times.

I have tried when the phone app is looking for a generic device. I have tried when the app is looking for the specific device. I have tried to run the exclusion process even though I never had it connected. I created a device with the web portal and then deleted it with the phone app like someone suggested for another Ecolink device. I have pulled the battery out for 20+ minutes and then tried the inclusion process. Nothing seems to work.

Like I said above, this is my first device so I do not know if I am missing something. Does anyone have any suggestions?

Thanks.


(Darryl) #2

What distance are you away from your hub?

I have 5 of these, the last one which I got Sunday paired in 10 seconds. I pulled the battery tab, set it next to the hub, and seconds later I was all set…

You may want to reach SmartThings support if you still have troubles, or try and swap the device with another one (exchange).


(Fast, Good, Cheap...pick two.) #3

Seems like with one of mine I accidentally pulled the battery tab before I put the app in inclusion mode.

When I went back to pair the sensor correctly; I pulled the battery, put the app into inclusion mode (using the specific device type), replaced the battery and left the cover off until it paired.

I doubt that would make any difference but give it a shot and see?


(kelly conner) #4

The sensor and hub are about two feet apart. They are both sitting on my desk.

By the way, I have rebooted the hub a few times and still no luck. I have the battery out now and I will try it again when I get home tonight.

Thanks.


(Darryl) #5

Also pull the battery, leaving it unconnected for an extended time. I also think I recall a button behind the ecolink… I think that may force pair it? I will admit the first one I had, was equally as odd/difficult to pair. The other 4 have been effortless.


#6

I’ve had similar problems with Ecolinks. Try excluding it first, and then including it.


(kelly conner) #7

Still no luck. The battery was out for about six hours and when I tried to link it I had the same results.

Darrylb, the only button on the Ecolink is a button that is pressed when the cover is installed.
Johnc, I have tried to exclude it. Nothing seems to happen.

I tried to link a First Alert Smoke/CO alarm today and it will not link either.

I assume the hub is working. It recognizes my phone when I get near my house. At least I assume that is the hub that is doing that and not just my cell phone.

How do I make sure the z-wave network is working? When I look at the hub information on api.smartthings.com it shows a HomeID, NodeID is 01, PowerLevel is 00, SerialVersion is 0, Version is 0. Does this look right?

When I go to the utilities page and click Repair Z-Wave Network I get Z-Wave network repair initiated - Click to view progress. And then nothing happens. When I click to view the event log is blank. I have waited 15 minutes and I have waited 3 hours and nothing happened. Should this do something?

Any help would be appreciated.


#8

@kelly, after kicking off the repair, go back to the main hub screen and then scroll down to List Events and click on that. When the next screen comes up, click on “from Hub” to see the events specifically from the hub. You will see the repair initiate and then complete. It can take a while, but if you do not have any electrically powered z-wave devices you will not need to repair the zwave mesh. Battery powered devices do not act as repeaters, so they are not part of the zwave mesh network, they just use it to communicate back to the hub relying on electrically powered devices to route it back the fastest way.

It sounds like to me that you definitely need to perform an exclude (via the app on your phone), but you said you did that. I’m assuming you removed the battery for 10 seconds or so before putting it back in, and then the exclude process did not come back saying it removed anything? BTW - your hub is set right, and looks just like mine.

When you are including it, are you selecting “+ Connect New Device”, or “Open/Closed Sensors” and then selecting Ecolink Door Sensor? I recommend just using “+ Connect New Device”. I have 18 of these things, and that’s how I’ve connected them.


(kelly conner) #9

With the help of tech support I got it working. Power cycling the hub seemd to do the trick.

Thanks for your help.


(Janet Davis) #10

I had the same frustration trying to pair the Ecolink Door Sensor using the Open/Closed Sensor and selecting Ecolink from the list. Duh, you think that would work! When I read johnconstantelo’s comment about using the plain Connect New Device option, it paired in seconds. Weird that. My plan for this is to attach the sensor to the stairs to the attic and turn on the Cree LED bulbs that I have paired for this purpose and that will go into the attic.


(Felix Max) #11

@johnconstantelo your suggestion on how to connect is spot on!! Thanks!


(C.T.) #12

I had a similar issue with the pairing not working regardless of what I tried. I opened the sensor and noticed a small micro sensor that I depressed for a few seconds and once I did, my SmartThings Hub recognized the sensor in a few seconds.


(Chris) #13

To get the door sensor back in inclusion mode. I placed the pull tab back in and closed the case. Pulling the tab back out again started inclusion mode. Good luck.


(Arun) #14

I have one problem in Ecolink Z wave Door/Window sensor
I am interfacing the Ecolink Z wave Door/Window sensor in Aeotec Z-Stick S2 for the pairing the inclusion mode, i don’t know the two devices pair or not.But the Z wave D/W sensor led is not blinking for many hours. And i am removing battery in the sensor and i reinsert the battery the process is not changed .Still the led is not blinking.
What is the solution for this problem?
Please share your suggestions.
Thank you


#15

I just had the same issue with linking my ecolink door/window sensors to the SmartThings Hub. This was due to prematurely pulling the battery pull tab. I tried many of the things listed above with no success. I finally did the following and it worked and linked immediately.

  1. Remove the cover and battery from the ecolink door sensor.
  2. Put the battery pull tab back in and reinstall the battery making sure the battery is not making contact. I actually had to use a strip of paper because I couldn’t find the original pull tab.
  3. Replace the ecolink cover. I found that this was the key. The cover presses a small button on the unit and it seems the button has to be pressed to link.
  4. Set the SmartThings hub so that it is searching for a new device
  5. Pull the battery tab on the ecolink. Don’t pull the tab until the hub is searching or it won’t work for some reason.

Doing the above worked great. I subsequently installed 3 more ecolink door sensors without problem. As mentioned I think the key is that the battery tab can’t be pulled until the hub is in search mode.

Hope this helps someone.


(Srikanth) #16

@109jb I really want to say thank you for writing the steps. This is very helpful. I have created an account to say thank you


(Kampto) #17

Similar issue… I have 2 Ecolink Door sensors that were working fine on my VeraEdge. Deleted them from my Vera and unplugged the Vera. Tried all of the above to get them to pair to my Smarthings V2 hub. Doesn’t find them. A couple weeks ago I was able to connect my Eco link PIR sensor so I know the Z-wave network is active… Any new tricks to pair these?


#18

I was able to finally pair my Ecolink Open/Close sensor by removing the battery, holding in the little black button, replacing the battery. Keep the button pressed until you are fully paired in the Smartthings app.

My sensor was previously paired with a Piper NV. I no longer have the battery tab. It’s not necessary.