Echo won't discover devices

Yep I did that but wasn’t working still…must be a problem on amazons side. Smart things app is working fine

I picked up a ST v2 yesterday and was able to easily integrate it with my Echo, and control the receptacle box that came in the kit, and a MyQ wall switch and receptacle box. I was was also able to Open my MyQ enabled Chamberlain garage door opener (still can’t get it to close though)…using Jason Mok’s code via my Echo.

On the heals of things going fairly I went out and purchased a couple of Cree bulbs, a couple of GE Link bulbs, and a GE In-Wall Z-Wave Smart Receptacle today. All of the new devices added pretty easily onto the the ST hub, and all devices can be controlled by the ST Android App. The issue I am having is that none of these are discovered by the Echo App. I’ve searched multiple times, deleted and re-added the devices on the ST hub…and still no dice. I am assuming that I should be able to control these without other hardware, but giving the issues I’m having, I’m not sure what’s up. Any insight would be appreciated.

Thanks,
WestsideBill

Welcome aboard! You’ve come to the right place.
In the ST app take a look “SmartApps” tab.
Then click on the “Amazon Echo” app.
Click on “My Device List”
Now, select the devices that you want Echo to control.
Click Next until you reach Done and click on that.
Now, do a discovery in the Alexa App and you should be good to go.

Note Whatever you name the devices in ST is what they will show up as in the Alexa App.
So give your devices natural language names you can remember (and the family can remember). You don’t want to name the Light in the kitchen by the microwave LKM1. I’d call it microwave light.

Also, if you have a bulb or some other device like a Phillips Hue bulb that also connects to its own hub, do not authorize Alexa to see those in the ST app. It will see those items through its own integration with that particular hub. If you click on it in the ST app as well there will be two instances of it in the Alexa app… and that causes all kinds of trouble.

Have fun and don’t worry about asking questions… that’s what the community is here for!

2 Likes

OMG, what a dope I am! Thank you so much Bamarayne.

Now, back to trying to figure out why I can’t get Alexa to Close my garage door… :frowning:

Hey, no problem. That’s a really common oops we all made.

What garage door opener are you using?

It’s a Liftmaster 8500 with the MyQ gateway. I installed Jason Mok’s code, and it is having no issues opening…I just can’t get it to close. Alexa accepts the request and says “ok”…but sadly nothing happens.

On the upside, I installed 5 new GE Smart Switches today (all in one junction box…which let me say was no easy feet to squeeze in), and despite some electrical challenges (I found that I had to connect the white wires to the “Common” terminals on the switches, despite the fact that I simply had them all wire nutted together for the previous switches/dimmers). Once I finally clued in to what was going on (two hours of my life I can’t get back), I had no issues getting them added in ST and working with Alexa.

I had the same problem. The Echo Discover Devices would not add my new Smartthings device so I selected forget all devices and groups in the Alexa app. Now, no Samethings devices are recognized. I do notice that the Smartthings devices in the Echo app shows as my device list as [object Object]. I thought they would have been the Smartthings object name.

Everything was working until I perform this.

The “object, object” is a new problem that occurs when you try to link a third party account like Echo or Harmony. Just started a few days ago. Doesn’t affect devices already authorized.

http://thingsthataresmart.wiki/index.php?title=Bug:_object,_object_instead_of_device_name

I am having the exact same issue. It started with Echo not being able to control devices. So I unlinked and now I can find devices when I relink, but they cannot be discovered via the Alexa app or when I ask Alexa directly. I have restarted everything.

I am having the exact same problem. alexa was having trouble with some devices so I unplugged it and then asked her to find my devices. she responded none could be found. She was able to control some that she had found previously. Tech support at Amazon suggested I forget all the saved devices. That was a mistake because she no longer finds any devices and has nothing saved to fall back to. Tech support says they will escalate this to the next level and will call me back within two days. So for now I have 25 devices that worked yesterday using echo and none today. I have a mixture of Belkin wemo and Phillips hue. None of which can be found. NO router upgrade or power outage. I wonder if they pushed a firmware out that broke discovery?
All my devices work using the Belkin and Phillips Hue apps as does Wemo Manager from the play store.

Do you have multiple locations? If so, make sure the Amazon Echo smart app is not installed in more than one.

1 Like

I had the Echo app installed on multiple locations. That was my problem. Once I limited it to the one hub location, everything was discoverable.

1 Like

Do you mean you had multiple Amazon Echo devices (dot, etc)? And the Alexa app was configured with both of them? If so, how did you limited it to one hub location? I can’t see any of the new devices I’ve added today after multiple discovery attempts, only the old ones.

THANKS!

Did you individually authorize the new devices from smartthings to echo before doing the discovery? You can do this either in the SmartThings mobile app or in the echo app.

See steps 10A) and B) in the following ( except for 10A) if you have the newest version of the SmartThings mobile app you will get to smart apps by first clicking on the three horizontal line menu icon in the upper right and then clicking on smartapps)

1 Like

I just got my smartthings home monitoring kit last night and the setup was nice and easy. Yet Alexa cannot find a single smartthings device. I looked through multiple FAQs and forums and followed directions from the smartthings site word for word yet Alexa cannot find anything from the home monitoring kit, only thing it finds is my sensi thermostat.

Does anyone have any suggestions?

The only device from the Home Monitoring Kit that is discoverable by Alexa is the outlet. There are a couple different reasons why a device might not discover, but if you’ve followed these steps, feel free to email support and they can dig into your account.

1 Like

I really like my echo, but unlike HomeKit, the echo itself doesn’t connect with any of your devices and doesn’t monitor sensors of any kind. All it can do at present is accept voice requests to turn switches on and off and control thermostats. It then passes those requests along to the actual home automation controller, in this case SmartThings. The SmartThings smart plug counts as a “switch” so definitely echo should find that. But it won’t find any of your sensors.

So definitely contact support to get help with your smart plug. But that’s the only device from the monitoring kit that echo will find.

EDIT…
Did you go into that Amazon echo smartapp and authorize the devices to be seen by the echo? The smartapp I mean is the one you find under your smartapps tab in the ST mobile app.

1 Like

Thank you for the help guys, I wasn’t aware that Alexa wouldn’t discover the sensors. and i also didnt authorize the outlet which I installed today.
it all seems to work fine now.
once again i appreciate the quick responses and help from everyone.

1 Like

SImply PRICELESS tip. Spent weeks trying to get this working until I came accross your comment. Congrats and a million thanks…