Echo and Echo Dot - Firmware versions UK?


I’ve have an Echo, and recently acquired 2 Echo dots (gen2).
With regards to firmware versions I’m not entirely sure that I have the most up to date, so wondered if someone can compare their versions?

Echo - 4172
Echo Dot 1 - 564186420
Echo Dot 2 - 561179920

According to the uk amazon page

My Echo is up to date and fine, however it mentions that the latest for the Dot is; which is does not relate to the version numbers I have?
In fact the version numbers appear to be US base, so makes me wonder?
Can anyone with uk Dot (gen2) confirm the above?

I’m not too sure how I go about updating this? Or if it just does so automatically?



I have both Echo and Dot bought from Amazon UK

Echo 1 - 4172
Echo 2 - 4172
Dot - 564186420

Echo 1 updated to this version within hours of initial setup.
Echo 2 updated to this version after about 4 weeks of use.
Dot updated almost immediately.

I cannot remember the previous versions.

I don’t think there is any way to force an update - it will happen as and when.

You can force an upgrade by pressing the mute button on the top, after 10/15 minutes it will automatically upgrade itself - if there’s one available.

Its in the manual/online help.

It’s not in the manual in the current packaging.
Just received it this week.

Do you hold mute button, and for how long? Or do you mean leave it on mute mode? And how long?

My software versions are the following:

Echo - 4172
Echo Dot - 564186420

Anyone know how to force an update on the Dot? Is this genuinely possible as mention by user Shaun above?
I have had the device connected for 24 hr. have tried switch off, unplugging several times. But still no joy?

With regards to the Dot in the older firmware. I’ve notice some problems as it does not alway work in conjunction with the Echo very well? For voice commands issued closer to the Dot, I’ve notice they don’t always get picked up and instead are responded by the echo?

At the moment I’ve tried leaving the Dot in mute mode for the past hour or so. But still no update as suggested by user Shaun?
None of this is mentioned in any if the enclosed manual docs…so makes me wonder if this advice is incorrect?

Anyone with advice would appreciated

Finally got updated after about 4 hrs in mute mode!

Good to see that it works - I’ll give it a try tonight.