EATON RF9640-N Dimmer

I am using the default device handler (secure dimmer) as setup by the QR code and it does work, however the app doesn’t correspond correctly with the switch when using the physical buttons (both on/off and dimmer). So the lights could be off but looking at the app, they show on. Same with the dim level.

I am just using this switch only and NOT with an accessory dimmer. Perhaps this is the wrong device handler?

That is the correct handler, however I changed mine to Zwave dimmer and it performs much better

I’ve tried “Z-Wave Dimmer Switch Generic” and it still doesn’t update the app when physical button press (on/off). The physical dim switch seems to update the app with the correct value though… However when I use the app to dim to say 50%, the light will dim correctly, but it immediately jumps to a random incorrect value in the app.

I have two of these dimmers and they’re both doing the same thing. My GE dimmer is working as it should.

Try resetting them by flipping the breaker off for a few seconds and then back on . I have 4 of these and they work correctly by app or the switch and show correct in the app

I’ve tried turning off at the breaker, I’ve done local resets, removed/added, tried different drivers, repaired z-wave. Strange… It’s almost like the signal is spotty but it isn’t that far from the hub and there’s a GE dimmer in the same room that’s working. Not sure what to try next. I hate to give up.

Very strange behavior indeed. Since youve tried all that, it does seem as though it must be a signal issue

So, it appears that turning the physical button on will register in the app, but turning it off does not. HOWEVER if I long press the button for 2 sec (delayed off time) it does register. The default delay is set to 10 secs. Getting closer.

1 Like