Eaton Z-Wave Plus integration with SmartThings (3 way switch)

I have multiple 3 way lights in my basement.

For each of them I have Eaton Z-Wave Plus Dimming switches, the RF9640-N is the universal dimmer and the RF9642-Z is the accessory dimmer.

The Universal Dimmer is wired to the lights, the accessory dimmer just has power, and controls the light via RF signal to the Universal Dimmer.

I have an Aeotec Hub using SmartThings to control everything. I have no issues adding the dimmer to SmartThings. I was also able to learn how to use Z-Wave Tweaker to get the Accessory dimmer to communicate with the Universal Dimmer . I have no issues controlling dimming or turning the lights on/off from either manual switch.

The problem seems to be the SmartThings app, or comms from the switches to it. In SmartThings both dimmers show up as unique devices, and SmartThings doesnt properly show the on/off status of the lights.

EX: lights will be off, the LEDs on the dimmers show the light is off, but Smart Things will show one of the dimmers as off and one of the dimmers as on. It appears that the dimmer displaying as on will always be whatever dimmer was not physically pressed.

ALSO if the lights are on, and I use the APP to turn off the Universal Dimmer, it will turn off the lights, but leave Accessory dimmer displaying “on” in the app.

My question is how do I get the app to show/represent the current state of the switch? Maybe I missed a Tweaker setting somewhere?

I have this same issue. Did you get it resolved?

When you use direct association to allow the accessory switch to be the trigger for the master switch, the hub is not told that this happens. That’s pretty much the definition of direct association. The idea in the Z wave specification is to have a way for devices to communicate which does not require the hub. This all made perfect sense back in the early days of zwave, but nowadays when everybody has an app, it means the status in the app may be out of sync.

There are two ways to handle this, but I am not sure which will actually work with the current architecture. So it may just be a matter of trial and error to see if either method does work.

METHOD 1: CREATE ROUTINES TO SYNCHRONIZE THE TWO SWITCHES

The simplest way is to create a routine to force the two devices to mirror each other. Well, actually two routines. You Used to be able to do this with the official smart lighting feature, but since that feature will be going away when the smartthings-hosted groovy cloud goes away, it’s better to do it with routines.

You just want to create a routine that says when the accessory turns on, turn on the Master. And another routine that says when the Master turns on, turn on the accessory. (I don’t know if you need yet another two routines to do the same thing when they turn off, someone else will have to comment on that detail.)

This should work to keep the app in sync with what actually happens with the wall switches. The only danger would be If the switches go into a loop, but I don’t think that’s going to happen, historically it has not with these models.

So this method should be pretty straightforward and easy, it’s just going to use up some routines, and you do have a maximum of 200 routines for smartthings.

And if and when they ever add a “mirror“ option to the routines (there was one in the official smartlighting feature, but I haven’t seen one yet in the new architecture routines), then that would reduce the number of routines that you need.

METHOD 2: ADD THE HUB TO THE ASSOCIATION GROUP ALONG WITH THE MASTER

The second method used to work, but I don’t know if it still does. You just have to add the hub’s ID to the association group for the accessory switch at the same time that you add the Master switch’s ID. This lets the hub know when you press the accessory switch at the wall. So it should update the app status. But again, I don’t know what happens with the new architecture.

It’s possible that neither of these methods work now, smartthings has never officially supported setting up zwave associations and there are gaps in its Z wave implementation for that reason. :thinking:

@philh30 has been doing some work with zwave and the new architecture and may have more information in this regard than I do.

Good luck, let us know what you try and if it works.
@jlanting