Do not disturb in wake up routine (Samsung 21 Ultra)


I am using a SmartThings wake up routine that turns on the lights when the morning alarm goes off. I am trying to get the routine to auto turn off ‘do not disturb’ on my Samsung 21 ultra, but without any luck. I’ve tried with Google home routines (since they officially have this feature), but it seems that it is not working on android 12.

Do you have a fix/workaround? Any help would be greatly appreciated!