Disappearing devices (only in Android app)

I am using Smartthings (for years) on a Samsung S21 Ultra
Devices and smartapps suddenly disappeared from the app.
I can still see the scenes and routines.
I can still see “Personal Devices” , direct connects like earbuds
In the PC Windows browser app on my computer all devices, smartapps, routines, scenes are available and functional.
Here are the things I have tried on the phone.
Rebooted the hub
Uninstalled/reinstalled the phone app (no change)
Cleared the cache for the app (no change)
Cleared the data for the app (no change)
Reinstalled the Arlo cameras by reconnecting to the service. It showed all five cameras on the Add Device screen but none on the Devices screen
Deleted a device (door open-closed sensor) in the browser app. Re-added it using the phone app by scanning. It found the device, allowed me to change the name on the Add Device screen but does not appear under Devices (or in any room). It does appear once again in the PC browser app.
I have added scenes and devices to Favorites using the browser app but on the phone all that appears in Favorites (phone) is the Weather Channel.

Any clues ??


Contact ST support on this

Thanks, I’ve already opened a ticket. I was trying to cover my bases. I’ve already gotten a response from tech support asking me to do those things that I listed as having been tried. I’ll stick with it and see if some good can come out of it when they get past the stock reply.


keep us informed if they identify the issue and resolve it or other.

Same issue here and have already performed the steps you listed above. It seems the ST devices are still attached to the hub and sending alerts but the app doesn’t show any of them on the home Favorites screen or in the rooms so they can’t be controlled. All automations are still there as well but I can’t edit them because the devices in each automation is unknown.

A backup Android phone that I only power on periodically has an older version of the app and all devices are listed in the Rooms but not on the Home Favorites screen which has now synced with the updated blank screen across Android devices. Only see Weather widget on that screen.

Please keep us posted on any resolution. Thank you.

Thanks for the response. I’ve given them everything they’ve asked for. We’ll see. BTW the app on my wife’s iPhone works just fine.

As a somewhat humorous aside. I discovered the problem yesterday when I came home and attempted to deactivate the alarm. Since I was unable to do that I finally just entered and set off the alarm (shrieking siren). After three minutes (default timeout) the siren didn’t stop so I unplugged it from the wall hoping the battery would run down. After another twenty minutes of shrieking siren, I buried it under multiple pillows and blankets. Fortunately I discovered the web app and was able to turn it off.


1 Like

I have the same issue and submitted a ticket with support last week. I just got the following response today by email.

"Upon investigation, we see that there is currently an issue that is affecting multiple users and is preventing the devices from appearing in the app. Our engineers have been made aware of the issue and are giving it high priority, so we should see a fix for the issue shortly. We would like to inform you that the devices are still on the account and that this is only an app UI issue.

We apologize for the inconvenience you are facing right now and we promise that we fix this issue shortly. Also, thank you for your patience while we work to resolve this."

Wow! Interesting.

1 Like

Thanks for the response. I wonder how widespread it is.

As an interim measure, since the issue is with the app UI, you could build a mobile dashboard of the devices that are missing and you need to control using a SharpTools dashboard. You won’t gain access to settings, but you can control things like on/off, dim, see contact status, etc. I regularly use mobile dashboards in lieu of the app.

1 Like

The issue has been fixed for me tonight without an app update. It might have been something on the server side.

1 Like

Can also confirm that my devices have reappeared in the rooms. My Favorites home screen is still blank and will need to be repopulated.

i have the same problem and its not fixed for me yet.

Last night I noticed the email from AwsmSpaceMonkey. I checked and discovered that my devices had reappeared and were functional except for my Arlo cameras. They were present but not functional. I deleted and reinstalled them without problem and they were once again functioning.
However, today I noticed that the Arlo cameras although still present, were not functioning. A delete/reinstall once again fixed the issue. I wonder if they are still making changes. I have not heard anything from Tech Support.