Dimming Level Being Ignored in Automations

I have had several simple automations working for years now and a few days ago they stopped working.

One is a simple motion automation that will sense motion and set several lights to a 10% dim level. All of a sudden they are coming up 100% and completely ignoring the set dim level.

Suggestions please?

Thanks very much!

1 Like

That’s interesting. Which devices are these and what kind of automations?

The reason I ask is that users of the big three third party legacy SmartApps (ActionTiles, SharpTools and webCoRE) have been experiencing problems since early last week with setLevel not working on certain devices, and indeed the Switch Level capability seemingly having disappeared from those devices.

The common element to these devices is that they are cloud to cloud integrations, so things like Lutron Caseta dimmers and a variety of Wi-Fi dimmers.

What we haven’t had yet is any reports of problems with other types of integration or with other apps. One might perhaps expect Smart Lighting to have the same problem as the other legacy apps.

The users are able to control the devices directly from the mobile app and there haven’t been any reports of issues with app Routines or Rules so far. It seems very much an issue with C2C integrations on legacy SmartApps.


I have one automation for a smart bulb that is still running through the Smart Lighting app, simply because it allows me to specify more than 60 minutes before sunset as an “on” option.

I swear prior to last week there was an option to specify the light level when turning the light on, but that option is gone now (and the missus is annoyed by this).

My light now comes on at whatever level it was at when it turned off.

All of my zigbee devices are using Edge drivers.

There is indeed a turn on and set level option. I created a virtual dimmer with an Edge driver just to test it and it worked fine.

If it doesn’t show for a Zigbee Edge driver that could be diagnostic. I know @joshua_lyon had a user report the problem with what seemed to be an unexpected device but I don’t know if more was discovered.

Update: webCoRE users are reporting things seem to have been fixed. That was about three hours before I wrote this.


It’s odd.

If I create a routine I get all the options for the bulb including dimmer level, but if i create a Smart Lighting automation, I only get On, Off, or mirror for options.

I created a virtual edge device using vEdge Creator, changed the driver to be the same as the driver on the smart bulb having the issue, and I get more options including a dimmer option.

The option to set the level in the Smart Lighting app has returned.

Whatever they did for the controller issue restored the functionality.


It is through Smart Lighting. Any suggestion to replace?

Like magic, it has started working again with no changes by me. Thanks everyone for taking time with this!

1 Like