Potential bug in Smart Lighting for v2

Pretty simple scenario. ST motion sensor in my office and a smart dimmer (ZWave). I have an automation using Smart Lighting (v2 hub on latest firmware) that turn on the dimmer and sets a certain level (in my case 40%) when movement is detected. This part works like a charm.
Now, assuming I need to increase the level of the dimmer to 100% because I need more light in the office. The moment the sensor sees movement triggers the above automation which totally ignores that the light is already on and dims it back down to my preset on the automation (40%). Very frustrating when you need more light because no matter what you do you end up at 40%. IMO this is not expected behavior. It would seem normal that if the light is already on, the automation to bypass the whole sequence of turning on and setting the level.

Is this by design? How can it be made to behave ‘normal’?


This is how it’s designed to work. When it says “Turn On and Set Level” it’s really just a single step that sends a set level command, so if it’s off it’ll go on and to that level. If it’s on, it goes to the level. There’s no way around it with Smart Lighing. You could probably do what you want with rule machine, but you’ll lose offline processing that comes with smart lighting.

So in the code for the Smart Lighting app is it not possible to get the status (on/off) of a light) before the set level is invoked? I have not written code against the ST API but I write code for a living and this is something not too hard if the API has the necessary support.

It would be fairly easy to write a smart app to do this and I think the rule machine app you can find here in the forums will do it (I’m not currently using it). The only downside to those 2 options is if your Internet is down it won’t work whereas the smart lighting will if you’re using a standard ST device type

1 Like

Definitely a disadvantage not to run local in this case, I agree. But I still think ST should fix their app to behave a bit more ‘normal’. In the meantime I will skip the set level since last used level will be remembered anyways.

How can I submit an official bug report on this?


What is “normal” to you may not be normal to others. The automation does what you told it to do :slight_smile: If motion is active, then dim lights to 40%. You need conditional rules, which unfortunately are not available in Smart Lighting. You can achieve what you need by using modes, which can give you the exceptions you need. Or you can use Rule Machine as @kevintierney suggested.