Did you know that when you add a device you can NEVER delete it?

Excluding / Deleting a device in the Classic App took about 15 seconds. I have several HOURS of work in the new app and I cannot delete a simple switch.

The error given in the app is that “This device can’t be deleted because it’s operating normally.” Really? Yes, it is working normally, but I still want to exclude it and remove it to replace with something else.

Even the FORCE REMOVE doesn’t work. When I try to Force Remove the app comes back and says it cannot do a Force Remove because the device is working.

So be VERY careful when adding Anything to the “New” SmartThings because you can NEVER get rid of it.

Strange… someone else was saying the same happened to them. But I have been able to remove and also exclude 3 devices over the past few weeks.

Try taking the device off power, wait five minutes, and see if it will let you delete it then. :thinking: (if it’s mains-powered you may have to cut the power at the circuit box.)


I powered the switch off for 10 minutes. Still no joy. This is a Z-Wave Aeotec Smart Switch Second Edition plug-in switch. I have several of these, they work perfectly with SmartThings you just can’t delete them.

When I attempt to delete, SmartThings reads “The device wasn’t deleted. Try following the manufacturers instructions again, or Forced Delete the device. (The manufactures instructions for deleting says to “Use your Z-Wave controllers app”.) or Force Delete the device. When I attempt to Force Delete, SmartThings comes back and tells me “This device can’t be deleted because it’s operating normally”.

On the switch itself, if you hold down the manual power button for 15 seconds you do a factory reset. When I tried to control the switch after doing the reset the switch does not respond, as I would expect.

All deleting methods continue to FAIL. Including Force Delete.

OK, I WAS able to delete the switch by logging into the SmartThings website on my Mac. Super easy. I’m probably the first person to say this, but I’ve become completely familiar with the new app. I like the old one much better.


I may be misremembering, but I thought Aeotec devices require 20 seconds for a reset. Did the LED turn green while you were holding it down?

When you hold down the switch, the light will start blinking rapidly after about 20 seconds. This is how I do the manual reset. (Sadly, the switch is always blue. Power indicators should never be blue.) Blue lights should always be avoided especially in sleeping areas. Just for fun, research “blue lights unhealthy” you’ll be surprised what you find.

Anyway, I have most everything working now, there’s an old iPhone on my device list that I cannot delete even using the desktop website. I’m not using mobile presents so I’m just going to ignore this for now.

I want to thank everyone for being so helpful. This is a great user forum that is reason enough to go with SmartThings. Almost as good as Apple’s Discussions.

1 Like

I had the same thing. Was replacing a Z-wave switch with one of the new GE Zigbee 3.0 devices.

Normal exclude failed twice before I tried force exclude (also tried twice). I deleted it via the IDE with no issues.


Hi, a while back I switched all my stuff from Zigbee to Z-Wave, I found that Z-Wave has better range and proved to be more reliable because the frequencys it uses are far away from Wi-Fi frequencies.

I did receive a reply from my support request from SmartThings (I suspect it came from outside the United States).

On iOS please clear the cache for the Safari application

Go to your iPhone settings
Navigate to Safari
Tap on Clear History and Website Data
Follow these steps:

Uninstall the SmartThings app
Restart the phone
Re-download the SmartThings app
Also, these steps help in clearing the error (if there is any) in the app.

Refer the link for the exclusive steps in the new app: https://support.smartthings.com/hc/en-us/articles/115002058563-How-to-exclude-Z-Wave-devices-

In case the issue persists, please help me with the below details to investigate the issue:

I have not done the above steps because I was able to delete the device by logging into my SmartThings account on my Mac, so I don’t have anything to delete for testing. I’ve added their suggestions to my notes in case this happens again.


I’m finding the same thing but with our presence sensors (phones)…my wife’s iPhone is listed normally, but my phone’s (I have a few I swap between) are listed twice for each one, one with my name in front of the device name and one with just the device name…can’t figure out a way to get rid of the duplicates and not really sure which ones the system is actually using.

I REALLY HATE THE NEW SMARTTHINGS APP. Samsung really screwed everyone with this piece of crap.

The new app would assign your full name + phone
The Classic app assigned first name + phone

1 Like