Did the Mobile update (Jan5) remove ability to view apps under automations?

I have connected SmartThings to Sharptools and I used to be able to add additional devices through the Sharptools application as per the sharptools community (per below). With the latest update, I no longer have access to “authorize unrecognized things”.

  1. Open the Samsung SmartThings mobile app
  2. Choose Automations tab and scroll down to find SmartApps section
  3. Find SharpTools in the list and tap it 1
  4. Tap the Next button to see the additional authorization types
  5. Select your additional devices 2
  6. Press Done

Does anyone know if this has been removed from the Jan 5th SmartThings update (IOS)?

Go to the Automations section, click on + in the upper right of the screen, choose Add Routine, tap on the Discover tab and scroll down to see if it is listed there.

Yes, I have done that, and sharptools is no longer there either. It’s actually quite odd.

You may want to contact SharpTools support.

Tagging @joshua_lyon

Do you have other SmartApps installed? From what I remember when this has happened in the past with iOS all of the SmartApps have gone missing. There’s a variety of different reasons.

SmartApp Spaces in Icons
If you have any custom SmartApps installed, you can check to make sure that none of them have spaces in the name for the icon:

Incomplete SmartApp Installs
You can also check if there are any ‘incomplete’ SmartApp installations from the SmartThings IDE :

Samsung SmartThings Support
Alternatively, some people have just had to reach out to Samsung SmartThings support to get the Automations tab working as expected again.


force close the app and open it again. That section will periodically disappear for me and comes back after killing the app.


Thanks for all the suggestions. I also have developer tools enables in SmartThings.
I put a ticket into SmartThings and have also force closed the app. I will continue to try a few things until I hear back. I’ll double check the “spaces on icon” but I thought I had taken care of that awhile ago.

UPDATE: went through everything again (as per @joshua_lyon ) and there isn’t an app that is “hanging” and there are no spaces in the app icons. That said, I hadn’t actually installed anything new since my Sharptools integration and it has all been working up until I did the update of the app. We’ll see what support has to say. The only reason, is I have added a few more devices and need to authorize my smoke detector whenever I “manage my connections.”

Thanks for all the help and direction!

1 Like

This happened to me these days… I had to disable developer mode and enable it again.

In my case, the apps disappeared when I collapsed the list and didn’t let me to expand any more.
Then I disabled and reenabled developer mode and it worked.

1 Like

@w35l3y I have tried this a number of times and still not working :frowning: Support wants a bunch of information so I will get that to them at some point today.

1 Like

It has been wonky for me too with the Android app since last update (but I think it was chalked up to ‘dev mode’ needing to be setup; and the strange organization / navigation path of the new phone appl. I have some smartapps under Automations tab (at bottom) as was intuitive, but some only show in the + / Discover path via the Automations tab. I guess some smartapps are used to create child/sub-apps for lack of better explanation and only publishes the new sub-app in Automations tab @ bottom: after creating the ‘parent app’ in IDE and the child/personal app in dev mode in the + / Discover area.

I think you are over complicating things. SmartApps are assigned classifications that determine if, and where, they appear in the mobile app. Those with the classification AUTOMATION appear under the Automations tab. By contrast a SERVICE would appear in the Life tab.

The apps you see at the bottom of the main Automations tab are the installed app instances. Some apps can only have one instance, others can have multiple instances. The apps you see bizarrely hidden in Add Routine > Discover are the apps that are still available for installation, either because they haven’t been installed yet or because they can be installed more than once.