Did anyone's hub just update to firmware 024.00020?

Whether it’s a good thing or not, it’s unacceptable to auto-update, especially without any notice or warning. I know of no other technology product that takes this approach. It’s your device, not Samsung’s. Not even Apple, famous for their tight control of their “ecosystem”, does this.
My Internet router, smart speakers, TV, PC etc all give me a polite notice that new firmware is available, and ask whether would I like to upgrade, or perhaps prefer to wait for a more convenient time…
This attitude is enough, on it’s own, to make me consider an alternative platform.

I’m not defending ST here but Nest puts out updates automatically and without notice and so does Amazon with their Alexa devices. I am sure I can think of others if I try.

2 Likes

After a reboot of the hub I now seem to get every time this set of lines. ZWave is ready and then ZWave power cycle has started.

Is anyone else seeing this after a hub reboot?

the z-wave power cycle is caused by the zwBadNode preceding it

Windows 10.

1 Like

Mine too.

Maybe they fixed the battery drain issue?! My presence sensor go through batteries like candy on Halloween! Wishfully thinking I know, but one can dream.

Do a zwave replace on that dining room dimmer switch to see if that stops.

Oh the bad node causes the zwave power cycle? What does bad node mean? When I am home again I can do a replace on the dinning room light, I guess. The last event from the dinning room dimmer was last night. Did the device have a hardware failure? Did the firmware update corrupt the entry for this device?

Regarding the v2 Hub firmware update, please see Hub Firmware Release Notes - 24.20

What kind of sensor updates? Does this fix the battery drain and or incorrect battery reporting?

It’s more like a restart. I don’t remember when, but those messages started a while back with another firmware release.

It just means it can’t be reached for some reason. Could be interference, dead, or just a very busy mesh.

Probably not. See my reply for the other potential reasons.

It shouldn’t have. Doing a replace, or even power cycling the switch via an air gap switch or a breaker, could do the trick too.

Mine updated at 2018-12-07 7:01 PM UTC
and I just noticed that my Philips bulbs are no longer responding, Ikea ones seem to be ok.

I haven’t touched this stuff for over a year, apart from pulling the battery to reset a motion sensor which stops working every so often, it’s been relatively stable.

According to the Devices log they stopped responding about about 9am UTC 2018-12-10, or much later than the hub said it updated, but I’m sure the 2 events are related as they have been running fine for so long.

I’m still running them as Kudled and ZLL Dimmer bulb devices. Am I going to have to repair them all? They are model LWB010.

Pulling the air gap on the dimmer resolved my issue.

Thanks for the help!!

1 Like

Well I rebooted the hub and Philips bulbs are either OFFLINE (ZLL Dimmer Type was set) or apparently ACTIVE (Kudled Color Bulb) but not responding to any changes (on/off, brightness %). Tried changing the Types and they alternate between these states but don’t come Online.

Also noted that not all my Ikea bubs are working, 2 in an extension bedroom are offline. Thought maybe they might have dropped off due to the mesh getting broken with the Philips bulbs offline, so I plugged a Smartpower Outlet in the room, which is working ok, but those bulbs are still offline.

The firmware update has not been a big success here I’m afraid.

I have 2 devices that went offline. One will require a power cycle using the air gap switch (a zwave switch), the other is a zigbee device (Iris contact sensor) that should require just removing/reinserting the battery to rejoin.

Same behavior I was getting with firmware 24.11

I have been turning these bulbs on/off with the mains switch. None of them are responding.

It will be a real pain if i have to re-pair them, 3 of them are in outside lights which will need unscrewing the enclosures to get them out to relocate them next to the hub. 8 bulbs will need doing unless there is another non-invasive solution.

The ‘ACTIVE’ bulbs behave normally from the app (e.g. give the ON status), but don’t actually do anything. The OFFLINE one just say ‘Turning ON’ or ‘Turning OFF’. I guess that’s just normal offline behaviour and the active state is not used anymore (I have read) so they are also probably just ‘offline’ in reality.

I am very fed up with this bullshit. I was going crazy last night wondering why my zigbee lights went berzerk. Got tired after troubleshooting for 35 minutes and went to bed, then I see this. I don’t know what the thinking is at samsung, but this the main reason I’m loving Hubitat, smoking fast local control and I update WHEN I AM READY. I have most of my devices moved over and waiting on an XBee delivery to finish my zigbee mesh
Any offers for my “stupidthings” V2 hub??

I feel your pain, bulbs should come back on it’s own. If not try an add a thing, it won’t find anything but might help the bulbs come back. My bulbs that went wacky are in the depths of my basement, and they came back after I ran add a thing, well after 8 hours that is

My hub (2015) went offline after the firmware update to 0.24.20. It comes online every time after I reboot but after few seconds it goes offline again. What should I do?

Contact Support @ support@smartthings.com

1 Like