Devices constantly ‘unavailable’

I love ST, I really do. But I find a lot of my devices, particularly motion sensors and open close sensors are constantly becoming unavailable. I’ve a webcore piston alerting me twice daily to check for this and I feel I’m forever trying to reconnect them by pulling the battery out of the devices but no sooner are they working again, they go unavailable again.

Is there anyway to stop this?

Need a LOT more info.

Are they zigbee, ZWave?
How big is your space?
How many powered repeating devices do you have? (of the type your sensors are)?
If they’re zigbee where is your wifi router located in relation to the hub, the sensors.
I’d this a new issue or has it always been a problem?
If they’re ZWave have you run a ZWave repair?
If it’s zigbee have you tried to reset the mesh?

1 Like

Thanks for quick reply.
Fast answer is they are all ST (3x) open close sensors and 1 motion sensor. Doesn’t happen all the time but has been happening more recently.

Haven’t did any repair. Didn’t even know this existed. How is this done?

The house is atypical 4 bedroom. The WiFi router is in the living room but not too far out from the sensors.

So ST sensors are all ZigBee. Unlike Z-Wave, there is no ST repair option in the UI and I believe you can force a repair by powering down your ST hub (from memory for 15 minutes at least). This forces the ZigBee devices into “panic mode” and they will rebuild their mesh when you power up your ST hub. Certainly worth a try.

To address the recurring issue, you might try strategic positioning of a ZigBee repeating device as @nathancu suggests , typically a smart socket/outlet.

Thanks. So also taking the batteries out too?
To add, I have a few ST plugs also. Does this extend the network and do they have to be placed strategically?

Yep, take the batteries out for at least 15 minutes to force ZigBee mesh rebuild (I believe, an expert may confirm/correct).
The ST outlets are indeed ZigBee repeaters but yes, they do need to be placed strategically. If you move them, remember you need to force a mesh rebuild again.


Thank you. I’ll try that.

That seemed to sort them all out but the motion sensor. Though this particular motion sensor has given me grief for months now. It’s on within the app registering temperature but absolutely no motion coming from it. Tried reinserting battery. Nothing.

1 Like