SmartThings Community

Devices keep disconnecting, frustrating (ST brand zigbee sensors)


(VMF) #1

I was pretty excited when i just go the hub2, however, after a year of usage, it is anything but frustrating and I am ready to give up on the investment and go with another vendor. Devices just keep disconnecting, and disconnecting in a way that they just die, hub still shows them as lets say closed or opened and the only way for them to come back is for me to either reboot the hub by removing batteries and power cabled or remove the battery from the device. Another issue is battery meter: does it friggin work? just replaced a battery in the motion sensor while the hub was still showing 77% on the battery while it was fully dead… I don’t even want to buy more devices, i already have 14 and lt looks like investing more time and money into this project is not worth it. Definitely not recommending this product to anybody. Is there a fix for this so called “smart thing” or was it a total waste of time and money?


(Bobby) #2

If you asked the same question about 2 months ago, I would have told you that you have a weak mesh and adding some repeaters will help improve your situation. But since you asked this question now, I can tell you that there is no answer to your question that you’d like to hear. Just to put it in perspective, I have over 100 devices and a rule. If a device gets stuck more than 3 times in a short period of time, either it gets replaced or I find a way to get things done without it all together. Well only this week I have retired 3 ST motion sensors and 2 contact sensors for exceeding my patience limitation. If things will continue like this, I will have no zigbee devices very soon, which will finally give me the reason to make the jump to a different controller.


(Ben W) #3

There are lots of reason of disconnecting.

Are they zwave/zigbee devices?
Do you have repeaters (having a good mesh)?

The battery being 77% then dying. I have a few “cheap” zwave sensors (Monoprice and Ecolinks) that report battery levels hardly ever. I have devices that been at 77% for ever, and checking they logs they never ever report.

I have over 100 devices. 30 zwave light switches so a strong mesh there. About 30 zigbee sensors, with a repeater. I get a drop out maybe once a month. Battery pull on the device brings it back. Have another repeater in a drawer I really should hook up.

With Zigbee I notice if I “Disable Unsecure Rejoin” I get a device drop every couple days. I have mostly Iris motion/contact sensors and I hoping with the new ST firmware, that will allow updating zigbee devices, they will start supporting this feature better.


#4

The SmartThings branded multi sensors have a current known issue (acknowledged by ST staff) where for some reason in some units the battery Reading is problematic at around the 66% level. They also sometimes start reporting just temperature and not other values. I don’t believe there’s a fix. If the device is still under warranty you should definitely report it to support.


(Ben W) #5

Was checking and I am not seeing battery messages for any of my devices. They used to show up in the list evens in the IDE.


(Brian Harding) #6

I love Smartthings so much that I keep buying more devices to hook up to it and hope that soon theses problems are fixed.

I hate Smartthings so much. I swear if this problem happens one more time, I’m going to …

go out and buy more device.


(VMF) #7

Thank you, this is exactly what happended…, at the moment i have only multipurpose sensors and motion sensors, all made by ST, i need to constantly restart the hub or remove the batteris from the sensors otherwise they just stop working i get no notification that some sensors dont send info at all. like you mentniond at least one stopped sending open/close data…


(VMF) #8

I only have ST devides when it comes to sensors, I even purchased the ST outlet to run as a repeater, the promiximty to the hub and rebeter for all sensors is fine, however, i still get dropouts all the time.


(Brian Harding) #9

@VMF
On a more serious note, I am not sure about your dropout problem, as I have not had any, but when batteries are dying the devices can start misbehaving. I have had several ST multipurpose sensors that would start giving me acceleration notices just before they died. At first I would move the sensor to another door and the problem would stay with that sensor. Taking the battery out and reinserting it would temporarily solve the problem until the device stopped working. Replacing the battery solved the problem. I routinely do a physical check of all my sensors about once a week by walking through all the rooms in my house and opening/closing every door while watching the Right Now page t make sure every device changes state. If not, I change the battery.

Unfortunately, the battery charge level of the ST devices is very inaccurate and ST does not give you a warning that the battery has died or that the device has stopped responding. My Arlo cameras can give me these warnings, so it should not be tooo difficult for ST to do the same.

Since you have had the system for nearly a year, I suspect the dying batteries might be part of you problem. Once you have ruled that out we can do further troubleshooting. I have had newly installed batteries read 77% and old batteries read 100%.


(Aaron S) #10

This feature is undergoing testing and will be coming out very soon.

This is kind of expected. The reason we provided the insecure rejoin feature was to allow devices to automatically reconnect when they hit a mesh network headache and fell off. Disabling insecure (the default) is more secure, but it also means there is no way for devices to reconnect.

I am re-acknowledging this. We have someone looking at the issue; I believe it was wrapped into the Zigbee OTA update work.


(VMF) #11

how do i enable unsecure join? or at least verify that this is enabled?


(Aaron S) #12

Here is our KB article on this: https://support.smartthings.com/hc/en-us/articles/208201243-ZigBee-Insecure-Rejoin-FAQ


(Ben W) #13

When that feature was published I immediately turned it on. More Secure == Better. Then I started getting drops. Took me a while till I realized that was the problem.


(Aaron S) #14

Right… and that is the default setting. Enabling Insecure Rejoin should reduce the number of dropped devices.


(VMF) #15

So for me to enable i should select: Allow Unsecure Rejoin (Most Compatible)
and then follow the rest of the steps in teh KB?


(Aaron S) #16

Yeppers! (did i hit the char count?)


(VMF) #17

you sure did, so instead of pressing the button i clicked reboot hub in the utils, is thatok?


(Ben W) #18

Did you check the setting before you changed it?