Device Timers not working

Has anyone else found that the device timers are unable to be set and/or fail to work?

Sorry, which device timers? There are a lot of different kinds of timers on the platform. And there are some devices which have timers built into them. :thinking:

So how specifically are you setting these timers? And what’s the brand and model of the affected devices?

Just the simple Timer function when you click on any device within the app. Please see attached screenshot.

Now, this feature did use to work but when I tried it today It was broken. I have tried the latest droid and iOS versions, both are the same so it doesn’t seem to be an app-based issue.

I can not longer use the timer to turn on or off a device in x-amount of time.

Can someone test this to confirm?


Works fine for me, except turning something on in one minute seems to be based on time of day. So if you set the timer at 15:37:40 it sets the time for 15:38.

1 Like

It worked for me with a Meross RGBW lamp and a Switchbot IR proxy.

What’s the brand and model of the device that’s failing?

in my testing… power on and power off worked but timer (power on or power off) does not.

Interesting. Mine were “placeholder” devices, are yours hub-connected? :thinking:

i only tested with hue lights connected to hue bridge

Local integration or cloud to cloud?

local. more details… i was selecting custom time of two minutes and not one of the set times.

just tried a timer on lutron and it did not work.

Ok, mine works with a custom time of two minutes, but yours is hub-dependent and mine is not. ( you can’t set up a local hue integration without a hub.)

Sounds like something is off, but it’s not clear what yet.

Another possibility… I see the OP already has a time schedule set up for that device, I guess the timer used to override that. Did yours have any other automations set from that screen?

nope… nothing set

for me, when i set a timer, save it, exit the device screen and go to the dashboard, return to the device screen, the timer is cleared out or should i say reset.


I tried creating a schedule first, my timer still worked. And it is persistent. So I’m back to wondering about hub-connected. Do you have any cloud-connected placeholder devices you could try?

timer did not work on a meross plug which uses a placeholder. but the timer did not reset when i exited the screen and returned.

It’s working on my Meross plugs, so, weird. I don’t have a hub at all on my account, but I believe @orangebucket does, so I’m out of ideas. :disappointed_relieved:

I too had this problem, you have to just restart your phone (or whatever smart device you are running) and this bug should resolve itself for the timer not being remembered.

Thanks to all for their assistance in trying to resolve this issue.

Everything seems to be working fine this morning with my Timers on all devices triggering properly, but I am not sure what resolved the problem.

Maybe after I restarted my phone yesterday the system just needed time to re-sync.

1 Like