SmartThings Community

Device setup for Leviton Switch in SmartThings for use with Google Home


#1

I can’ figure out what I am doing wrong. Last week I setup 2 Leviton DZ6HD-1BZ in two different rooms and they appear in SmartThings, Alexa, and Google Home. I can control the switches from all three apps.

Today I added a third switch in another room and I thought that I did it correctly but I cannot see it in Google Home. I installed the switch and then did the pairing with SmartThings. It then worked fine in SmartThings so I move on to Alexa.

I searched for new devices and it showed in Alexa. I only did the original pairing with SmartThings, I just searched for new devices in Alexa. Alexa works fine.

I then continued on with Google Home and just like Alexa I did a search for new devices and it did not find anything. I have retried several times and it is never found. I tried to do the pairing again directly with Google Home, but it still didn’t find anything. Should I have paired it originally in Google Home instead of SmartThings?

I am sure that it is just a stupid mistake on my part, but I am really new to home automation. I just got into it last week. I have tried searching the community, but I haven’s been able to find the answer. I can’t figure out what I am doing wrong.

Any suggestions?

Thanks in advance for your help!