Device routines and "local" vs. "cloud" execution

Overall I’m not displeased with the migration but I have a problem with a routine I’m adding to a smart switch.
I have existing routines that work fine. They are attached to a simple binary switch for my back door light. One routine turns on all the outside lights when I turn on the back door light, the other is for “off”. These routines work fine and all lights respond within a second of flipping the back door light switch.
I want to create similar routines for my kitchen sink light to turn on/off whenever I turn the kitchen ceiling lights on/off. These are dimmer switches not binary. However the response time is pathetic, sometimes more than a minute and sometimes never.
The big difference I see when looking at the API is that the back door switch is location “cloud” while the kitchen switches are location “local”. Also the the back door light switch is type “placeholder” and the kitchen switch is type “dimmer”.
I don’t know why the back door switch stayed “cloud” (along with a few others) while the kitchen is “local”. Is there a way to force “cloud” to see if this routine works better (or is that option going to go away too?). Although the back door switch was tied to a CORE routine at the time of the migration.
FWIW, I have a v2 hub with 29 devices.

According to?

The IDE is no longer authoritative nor accurate on this since Edge drivers…

Fine. Then why is the response so pathetic for this routine vs. the others?

Brand and model of each switch? :thinking:

They’re all GE switches, not sure of exact models.

Sounds like some of your devices might still be using DTH drivers. I’d use the SmartThings API Browser+ ... Now Available to All from @TAustin to check that all your devices are using Edge drivers. Also, for GE/Jasco devices, I’d suggest using the drivers from @philh30.