Device Refresh State


(DanG) #1

While testing some devices out today I just noticed a group of devices that don’t report change of state when manually turning on/off

  1. GE 12724 In-wall dimmer
  2. ZW3003 In-wall dimmer
  3. DSC061006-ZWUS Aeon Labs

I just noticed this and could of sworn they properly reported at one time but I cannot be sure. Is this a new problem, or something that has been around a long time?


#2

I’m not sure what the cause of that is. I have a couple that will fail to update state also. I tend to believe this is a mesh network issue. Meaning the network isn’t sufficiently robust enough to relay the state info back. But I may just be looking for the most simplistic answer.

I haven’t worried about this too much as it doesn’t stop any of the routines from doing their job. A routine to turn on lights will still send an on command to a light or switch that the app says is already on. It bugs me though that the light can be turned on and off by routines but not properly report it’s state. I share your frustration.


(Bobby) #3

You mean, they don’t instantly report the change? But they do some time thereafter, right…That is a device limitation, thanks to Lutron copyright…


(DavidK) #4

That’s weird, I was going to ask the opposite. Last night it seems device updates to hub from manually switching ge dimmer on and off seemed much faster than normal. Almost instant. Normally there is some delay.


(DanG) #5

How long is “some time”? I have tested these switches again and after 10 minutes still no update.


(Bobby) #6

Oh wow, that’s not good…I have a bunch of 12724s…I just checked mine, it takes 3 seconds top to report the correct state


(Bobby) #7

I just noticed the same, as I was testing mine…


(DanG) #8

All this suggests something happened on the backend that has, once again, helped one group of users and hammering another group. :dizzy_face:


(Bobby) #9

Do a hard restart of your hub, before you do anything else…


(DanG) #10

Did so once yesterday and again now. No automatic status update being reported from these three devices. Also power cycled each device with no change. I can imagine people at SmartThings pulling their hair out when conditions and problems seem to be different depending on the individual and not the equipment. Geeezzzz!


(Jason "The Enabler" as deemed so by @Smart) #11

Run a zwave repair. There may be an issue in the mesh


(DanG) #12

Before I do that, would a problem in the “mesh” still allow the device to be controlled remotely and at the same time not provide a status change when controlled locally?

I can get the switches to report their status if I use the app and manually refresh it. It just appears that these devices have stopped sending a status change on their own.


#13

That’s exactly what mine do, sometimes, not always. Most commonly I will have one z-wave and one zigbee device that will fail to update from off to on or vice versa. All my Zigbee devices are Cree bulbs. The Z-wave device would be one of 2 zwave dimmer plugs.

Sometimes if I refresh them several times the state will change to the correct one sometimes not.


(Bobby) #14

What device type are yours using?


#15

All of my Cree bulbs are using the Cree Bulb device type all z-wave dimmer modules are using dimmer switch device type.


(DanG) #16

The devices are;

  1. GE 12724 In-wall dimmer - Device handler: Dimmer Switch
  2. ZW3003 In-wall dimmer - Device handler: Dimmer Switch
  3. DSC061006-ZWUS Aeon Labs - Device handler: Z-Wave Metering Switch

(Bobby) #17

Ok, I ran out of ideas :slight_smile:


(Jason "The Enabler" as deemed so by @Smart) #18

I’ve had this problem before… Never with the aeon device, but with the GE in wall dimmer.

When I would run a zwave repair there was usually something messed up. And once it was fixed, all was good.


(DanG) #19

I will do that and report back.


(DanG) #20

ZWAVE REPAIR did nothing to correct the problem. The devices I listed here just don’t report their state anymore when being manually controlled.