Device is offline but it's not. Need an expert here!

Ok, here goes…

I have a WD500Z-1: Z-Wave Wall Dimmer Switch from Go Control.

I have had this for about 4 years and it has always worked perfectly in my network.

Let’s call this SWITCH B.

As of yesterday (nothing strange happened such as a power outage or issues with the network), it is showing as offline.

So if I ask Google or Alexa to turn it off or on, it says it’s not available.


It is part of two automations in SmartThings.

One is if SWITCH A is turned on, SWITCH B will turn on. If SWITCH A is turned off, SWITCH B will turn off.

The other is a physical stand alone switch that when pressed, it will turn SWITCH B on.

The crazy thing is that BOTH of these automations are still working even though it’s telling me that the SWITCH B is offline.

I’ve tried to reset the switch without any luck (nothing provided by the manufacturer seems to be working.)

I’ve tried to remove it from SmartThings so I can re-add it, but Samsung is telling me, first to follow the manufacturer’s instruction to delete which isn’t working.

Samsung then tells me that the device wasn’t deleted. So I try a FORCE DELETE. Samsung then tells me that the device CAN’T be deleted because it’s operating normally.


I’d really appreciate any suggestions. This one has me stumped.

  1. reboot your ST hub at in hubs > view utilities
  2. run z-wave repair. Go to Devices > All Devices > your hub, 3 dots in the upper right of screen > z-wave utilities
  3. if those fail and you choose to remove the device… do a general device exclusion in the same location noted for z-wave repair above.

Oh wait… you wanted an expert :wink:

All else fails… sign out of the app and sign back in

Did you ever set up a zwave association between those devices? If so, that will run even when the switch can’t talk to the hub. :thinking:

Offline status for hub connected devices is essentially a flag that indicates that the device health subsystem has not seen the activity it would expect from a device. With legacy handlers it doesn’t tend to recover to online without help.

The mobile apps take offline at face value and prevent users from interacting with offline devices in various ways. That is irritating but understandable. The API used to omit offline devices from device lists but has fortunately stopped that nonsense. It sounds like Google and Alexa also assume the connection status is accurate.

Other things may be indifferent to the connection status and just carry on regardless.


If this helps, I recently had a similar issue. I knew the device was fine, and I knew the hub was fine.

My solution, after a bit of frustration, was
A). delete the device from IDE
B) power down everything for 20 minutes (no battery backup on the ST hub)
C) move the device right next to the hub
D) power everything back up
E) wait 15 more minutes for the device mappings to rebuild themselves
F) add new device.

I did that because in IDE, I saw the device was following a path that was ridiculous.
The device has been solid and stable since that exercise.

1 Like

Thanks Glen.

I had a different solution. I killed the breaker to the switch. Brought it back on, and all was good.

1 Like

Thank you. My solution was to kill the breaker to the switch and turn it back on. Solved the problem.