[DEPRECATED] Free Ecobee Suite, version 1.3.*


(Barry) #1

PLEASE DO NOT INSTALL VERSION 1.3.0!!!

I just discovered a significant issue with version 1.3.0, and has been officially replaced with version 1.4.*, available here.

All users who have installed 1.3.* are requested to remove that installation and to re-install using 1.40 (you will NOT be able to install 1.4.0 on top of 1.3.*).


Thermostats with good SmartThings integration
(Joe m. ) #2

when i try to remove the old ecobee connect i just get an unexpected error, its the last exisiting thing i have to get rid of before trying out the new one. I also can’t delete it in the ide because it says its installed by more then one user, great instructions tho for this btw, any ideas?


(Joe m. ) #3

can’t delete the device handlers either, says they are still in use hmm. i’m sure i’m missing something simple.


(Jared) #4

Did you remove all the thermostat and sensor things? I suspect you still have one somewhere.


(Joe m. ) #5

in the ide it appears i have duplicates, i got rid of them in the old ecobee connect but i see them in the ide, working on deleting them in there now.


(Joe m. ) #6

got rid of one device handler


(Joe m. ) #7

ecobee connect still on phone app and i did get rid of all device handlers.


(Joe m. ) #8

Smartthings deleted it, I think all is well, once I get my smart vents integrated and working I will be donating for you berry. No drama thread has been great, appreciate what you do


(Jared) #10

lol, I get the reference.


(Barry) #11

Let me know if you have any more issues…not sure I can do much, but I’m constantly trying to improve both the software and the documentation.


(Kirk Hilzinger) #12

Connected to your repository and it does not take. I was able to update from the old repository. I used copy/paste to add it.

Owner: SANdood
Name: Ecobee-Suite (note that the hyphen is required)
Branch: master

The entry has a red delete next to it.


(Barry) #13

I am in the midst of a MAJOR RE-RELEASE. Version 1.3.0 has a serious bug in it, and I will be releasing a version 1.4.* momentarily.

Thank you for your patience


(Barry) #14

URGENT: Please uninstall v1.3.* and re-install using version 1.4.0 (see here for explanation why this is necessary).


(Joe m. ) #15

How important is it to switch? Not home for 11 days but might be able to do it all on a phone. It seems to be functioning so far


(Barry) #16

@Joe_Mcnelly

Since you removed the old version before installing 1.3.0, you should be OK. But you will need to completely remove 1.3.0 before you update your SmartApps or Device Handlers from the Repo - once you do that, you’ll have (another) hard time getting everything removed again.

Not that it helps, but I realized what I screwed when I tried to replicate your uninstall issue…sorry to have put you through this…


(Joe m. ) #17

It’s all good, I’ll see if I can get it done on my phone, much more painful but I think it will work because of Github integration provided, can’t do copy and paste stuff on phones, at least not a galaxy s7


(Jane) #18

I have just installed the Ecobee Suite 1.4 and I have a couple of problems. One is that the temperature selection setting shows that the temperature should be in Celsius, which is correct but the actual temperature in the ecobee Things is showing in Fahrenheit. How can I change this. See pictures. Also in the Ecobee Suite Manager when I touch Ecobee Suite Preferences nothing happens. If I touch any of the other options the next screen opens with the options available but nothing is happening with the Preferences option.

Also, what does the three question marks mean?


(Barry) #19

Those mean that the installation is not complete and/or has not successfully connected with the Ecobee Cloud yet (that’s what the frowning cloud means).

Try the double-refresh trick (hit Refresh, and when the Bee re-appears, hit it again). Also, look in Live Logging for Ecobee Suite Manager and the thermostat itself to see if any (red) errors are being flagged.


(Jane) #20

OK I did that and nothing changed in the app. Here is the log…
ea12490a-dca8-4ab6-854c-afcdbe895bcf 10:54:00 AM: error groovy.lang.MissingMethodException: No signature of method: script_app_Ecobee__Co_da964c2f_64b6_4182_9218_51a13dec772f_ver_8_4.pollChildren() is applicable for argument types: (java.lang.String, java.lang.Boolean) values: [411928495959, false]
Possible solutions: pollChild() @line 728 (refresh)
ea12490a-dca8-4ab6-854c-afcdbe895bcf 10:54:00 AM: info refresh() - calling pollChildren
ea12490a-dca8-4ab6-854c-afcdbe895bcf 10:54:00 AM: error groovy.lang.MissingMethodException: No signature of method: script_app_Ecobee__Co_da964c2f_64b6_4182_9218_51a13dec772f_ver_8_4.pollChildren() is applicable for argument types: (java.lang.String, java.lang.Boolean) values: [411928495959, false]
Possible solutions: pollChild() @line 728 (refresh)
ea12490a-dca8-4ab6-854c-afcdbe895bcf 10:54:00 AM: info refresh() - calling pollChildren
ea12490a-dca8-4ab6-854c-afcdbe895bcf 10:53:28 AM: info Updated 21 objects (211ms)
ea12490a-dca8-4ab6-854c-afcdbe895bcf 10:53:28 AM: info coolingSetpoint: 77


(Barry) #21

What are the versions numbers as displayed in Ecobee Suite Manager and the My Ecobee thermostat device (find in the configuration page)?