[DEPRECATED] Free Ecobee Suite, Version 1.2.*

Try this: On your ecobee thermostat is your ‘Hold Action’ in Settings>Prefererences set to ‘Until next activity’? If not change it and see if your ecobee changes this time with webcore.

Yes, it was already set to “until next activity”.

Some additional info: the device handler is ugly and ineffective. Pressing the ‘home’ button does nothing. In fact none of the buttons do anything. Yet Ecobee Connect says I’m connected…

Weird if i click on home at the very bottom of the device handler it changes my mode to home.

Also the webcore piston is working, it change from away with motion on x sensor and home with motion on y sensor.

Dont know what else it could be.

1.2.9 this is the version i have

It’s getting the events from the thermostat, it’s just not sending anything.

What does the Live Logging show for the the Thermostat device and for Ecobee (Connect) at the time of the WebCore request to run home()??

If the buttons don’t work in the Device Type Handler, then you may not have things installed correctly. Once you can change modes/programs using the DTH UI, THEN you should try WebCore - if the UI doesn’t work, there’s no way that WebCore is going to work…

Can you please provide a Screen Shot of your DTH UI, or at least the revision number as reported int he DTH Settings page?


See below images. Thanks.

This screen shot indicates that the device is not connected with its Ecobee (Connect) parent.

  • Did you create the device by hand, or did you use my version of Ecobee (Connect) to create it? If not the latter, you need to delete the devices, then the DTH’s, and then Ecobee (Connect) from your IDE. Then re-install as per the directions, allowing Ecobee (Connect) from my Suite to create the thermostat devices.

  • By the way, what is the version number of the Ecobee (Connect) that you are currently running?

(PS - The live logging for Ecobee (Connect) and for Thermostat should tell you a lot about what’s going on. But until you see a non-smiling Weather icon and the operating status for the thermostat (at the top, where there are “–”), you haven’t gotten it installed correctly…

Ok… I tore it all apart, and reinstalled. For the third time.

The first time I just installed the DTH. Was functional, but had no added utility.
The second, a couple weeks ago, I thought I got it all done correctly but it was still looking at the first install.

Lesson: if you do it incorrectly at all, you really have to dismantle the whole thing as specified in post 249 and then rebuild from scratch. It is now working correctly. Thanks for the assist!

Next steps:

  • get the ecobee geofence to work correctly and, in webcore, have it trigger security functions.
  • make a piston that, if it detects motion at any motion sensors in the house AND the thermostat is not already in ‘Home’ mode, put it in ‘Home’ mode.

I will deploy the Ecobee sensor in the exercise room; if occupancy is detected there, bring the thermostat temperature down a bit.

Ps - how do you mark an issue in a previous post as ‘solved’??

1 Like

So, using webcore to ensure the thermostat is in Home mode whenever someone is home:

/* Motion alerts ecobee to presence */
/* ******/

Motion Sensor’s motion is active
Thermostat currentProgram is not {$args.Home}
Pan camera to the Home;
end with;
end if;
end execute;

The line about currentProgram prevents it from triggering if Home has already been selected… else it would trigger all the time

Click the check-box under the post…

Glad that you were finally able to get it all working!

Hi There

I installed ecobee connect following the instructions given, my version is 1.2.9.

All seemed to go without issue, until I get into the smartapp. It let me select the thermostat however, when I look at all the helpersmart apps i says "there are no devices of this capability under the pick a thermostate heading.

It also doesn’t add a “thing” to my devices.

in live logging I see this error:

22:21:09: error java.lang.NullPointerException: Cannot invoke method format() on null object.

I would be grateful for any help anyone may be able to provide. I had my ecobee lite installed today and would love to have it working on smart things!




You should probably first:

  • Open Ecobee (Connect)
  • Log in to your Ecobee account
  • Exit Ecobee (Connect)
  • Open Ecobee (Connect)
  • Select the Thermostat Device
  • Exit Ecobee (Connect).
  • Wait a couple of minutes, then check the status of the Thermostat Device itself (it should have been created in the prior step) - once it is displaying temp/mode/weather correctly, THEN
  • Open Ecobee (Connect)
  • Create helper SmartApps.

I think it needs to exit Ecobee (Connect) to create the thermostat device…

I have a couple different issues…

The set temperature in my ST app does not match the actual set temperature on the Ecobee. It looks to be one degree low. It seems like it’s displaying the actual averaged temperature, rather than the Ecobee setting.

If I click on the adjustment slider (which looks vertical on my screen?), sometimes it will even make it one more degree lower.

The temperature is not adjusted using the up/down arrows to the right of the temperature at the top.

See screenshots…

Hi Berry, hope you are doing great!

Just a question. I have the following scenario at home:

Suite Master (with one dedicated Ecobee) and Suite Master Bathroom (with a Xiaomi temperature / humidity sensor). Before I changed to your Ecobee Suite (I was using the stock App) I had a core piston to monitor the humidity of the bathroom (if it is >65% turn on A/C Fan) to circulate the air when shower was on, and them after shower turn it off (<65% turn AC auto).
The thing is that after I moved to your App, I can’t make this rule working anymore because the auto option breaks the current program setting in Ecobee. So do you have any suggestions about how can I implement that?

BTW: I think I found an issue when I try to apply a specific temperature using routines (I’m using Celsius), it seams that the temperature applied at Ecobee is fahrenheit.

thanks a lot!


Any reason in sensors its always higher then what the stat shows? Cottage sensor is the thermostat

If you have multiple sensors configured to control the temperature, the thermostat itself will display the average of all of them. “Cottage” in your case is the actual temperature at the thermostat (which is why you need the remote thermostats, or those rooms would never get warm…).

1st, you should be able to turn just the fan on (use fanOn()). When you want to turn it back off, you should do a resumeProgram() instead of fanOff().

I will look into making fanOff() do that for you, as I think that’s what the original version did…

Indeed, internally the thermostat works only in Fahrenheit. Which routines are you calling - I probably broke the conversion for external temperature settings…