[DEPRECATED] Free Ecobee Suite, Version 1.2.*

Nope, just follow the install instructions meticulously. Designed from the outset to handle multiple thermostats.

1 Like

You’re one of the lucky ones, I guess. Lots of others are experiencing the same issues, so I know it’s not just me:

Let’s hope for a fix soon right

Important Notice:

As of February 11, 2018, I have released the new fork of this work as the Free Ecobee Suite, Version 1.4.0 (see the [announcement here]([RELEASE] Updated Ecobee Suite, v1.4.0 (Free) for important instructions on obtaining and installing this new version).

I have also simultaneously released most (but not all) of the enhancements in that new release as the Ecobee Suite, Version 1.2.90. Note that all future enhancements will be made to the 1.3.0 fork ONLY, and this version will soon be deprecated.

Note that all of the Device Handlers and SmartApps in the 1.2.* repository have been updated to reflect the common release number of 1.2.90. If you want to install this version, you will need to install ALL of the files in the repository.

Users are encouraged to move to the Free Ecobee Suite version 1.3.0 as soon as possible.


For more information, please refer to the new release announcement here:

Please be sure to read the updated Documentation for Free Ecobee Suite version 1.4.*

Also, please note that the GitHub repository for this new fork has moved to

As always, post comments, feedback and complaints to the appropriate Community thread for the release that you are using.

2 Likes

Resolved in both v1.2.90 and v1.4.0 (v1.3.0 was deprecated) - will silently ride out Timeouts from Ecobee…

1 Like

Awesome!

(I meant v1.3 - but I’m sure you figured that out!)

Yes, but you should move to 1.4.0 instead of 1.3.0

What is wrong with v1.3? I keep seeing mention of a problem with it but no specifics provided.

Among other things, v1.3.x will overwrite your current devices if you didn’t completely remove v1.2.x before updating your IDE with the new code. 1.4.x fixes this, but requires a complete re-installation (my apologies for that). Best to bite the bullet now…

UPDATE ANNOUNCEMENT
On Feb 12, 2018 @ 2:30pm, Ecobee (Connect) has been updated to version 1.2.92

Fixes in this release include:

  • Now handles javax.net.ssl.SSLPeerUnverifiedException as a temporary, non-fatal exception, as with Timeout exceptions
  • Now recovers more cleanly (and quickly) from transient (temporary) errors (like the two mentioned above)
  • Cleaned up unnecessary restarting (rescheduling) of the poll daemon

It is recommended that all users running 1.2.x upgrade to this ASAP

This is likely the last update to the 1.2.x tree. Users are recommended to upgrade to 1.4.x ASAP

Barry, I’m a 3 week user who just purchased ST Hub, some devices and an Ecobee4 thermostat, which I had someone install. Everything is functional.
I’ve successfully installed a ZooZ MS and a GE Fan Ctl DHs.
I found and want to install your Ecobee Suite DH v1.4
When I copied all the code lines, pasted the code into the “From Code” tab, and Hit “Create” I got the following error message

Groovy.lang.MissingMethodException: No signature of method: script_dth_metadata_8bab00fd_951d_4580_9477_7c7f065a838b.appSetting() is applicable for argument types: (java.lang.String) values: [clientId] Possible solutions: typeSetting(java.lang.String), typeSetting(java.util.Map), typeSetting(java.lang.String, java.lang.String), getSettings(), setSettings(java.lang.Object), typeSetting(java.lang.String, java.lang.String, java.util.List)

Sorry, I have no programming experience and have no idea what this error means or equally important, what I have to do to correct this error.
Sorry (again), I’m not even sure whether I’m posting this request in the right area.
I would very much appreciate if you would help me out.
Thanks in advance.

That error usually indicates that you may have posted Device Handler code into the My SmartApps page, or SmartApp code into the Device Handler page.

I suggest you have a look at this Community Installer - it does all the dirty work for you, and might resolve your problems quite easily…

I think I must have missed something. When I click on the Ecobee (connect), it doesn’t list my thermostat. I currently have Yracine installed but from what I’ve read, I don’t need to uninstall that first. Can someone tell me what I’ve done wrong?

Switch your Yracune thermostat device Type to the one ecobee suite uses. Have you installed ecobee suite??

From Github? I think I have

Go to your devices tab on your ide. Find yracine thermostat, hit edit, find device type for ecobee suite. Click save

Please don’t use the version that has “Ecobee (Connect)” - you should uninstall that, then install the Ecobee Suite Manager (version 1.4.xx).

Ok I’ll look for it. I got the Connec from Github

Just to make sure we are on the same page:

Check out https://github.com/SANdood/Ecobee-Suite/blob/master/README.md. If you have done that already then you just need to edit device types.

When you are done switching types it looks like this on your ide

Then you can proceed with the next installation steps.

DEPRECATED

Just a reminder that this version is no longer being developed or maintained. Interested users are encouraged to use my new Ecobee Suite instead:

1 Like