Deleting and starting over with MyQ


#1

I just got into ST with the Hub, some Aeon Power Switches and the MyQ Chamberlain garage door device. Long story…the MyQ was not working in Routines so when I messed around with it I did something to the MyQ device. I want to delete anything to do with MyQ and start over. In IDE and in the app I can’t delete MyQ: Garage Door Opener under My Devices or copy-ninja : MyQ (Connect) under SmartApps or copy ninja : MyQ Garage Door Opener under Device Types. When I try to Uninstall from the iOS I get “Device still in use. Remove from any SmartApps or Dashboards, then try again.” When trying to complete the MyQ install on the iOS I get “Failed to save page: prefListDevices”. I attached the log file screen shot.

Any help or suggestion on removing everything. Should I create a new account and start over?


(Ron S) #2

Start with deleting the SmartApps tied to your Garage Door device type. If you cannot do it from mobile app, try the IDE. Once you have deleted all the SmartApps tied to it, then delete the device type in the IDE. Force kill your mobile app and restart or better still logout and login.


(Ron S) #4

Will give it a shot tmrw morning! I have to get rid of it as well…


(Andy Kim) #5

I’m having the same issue, can’t uninstall MyQ smartapp from iPhone- says unexpected error. In IDE, I get the same message as you. I’m upgrading to the hub v2 and what a pain to remove all these apps. Please post how to remove if you figure it out.


(Jason Mok) #6

go into the SmartApp/Service Manager, remove all entries for acceleration sensor and contact sensor. save.

now go into the app again. uninstall.

p.s: the contact sensor option is not meant for the device that was created by the MyQ service manager. Ít is meant for external sensors like Ecolink Tilt sensor.


(Jason Mok) #8

Next step remove them from the SmartApps that are using them. You can identify them at “In Use By” in My Devices detailed view. https://graph.api.smartthings.com/device/list .

In order to remove the MyQ SmartApp, you have to make sure every user has it uninstalled first.


(Ron S) #10

Its in use by MyQ Connect. See you first screen.


#11

I see that it is in use but when I go to delete it it gives me the error. I can’t Uninstall it from iOS because I get a "Device still in use. Remove from any SmartApps or Dashboards, then try again.


(Jason Mok) #12

Check each and every user/device. Check each and every location.
You have to remove the contact sensor/acceleration sensor first because that’s causing the cicular reference and disallowing you to remove the app.


(Ron S) #13

I was using a different setup with non magnetic part of multi and RefreshMyQ app. Was using the MyQ Garage Door Device type. Got rid of the apps tied to it but still was getting some error (null exceptions on door_name) while trying to get rid of the device. I went ahead and changed the type of device to some arbitrary device in the IDE, saved it and then was able to delete it successfully. And then got rid of the device type.


(Ron S) #15

Scratching my head as I had a different setup . I didn’t have to remove my multi to get rid of it… In your position, I would request ST support to get rid of it for you. In the IDE, does it allow to get rid of the MyQ connect? I think it can be reached from my location -> SmartApps-> edit and you should see uninstall next to that app.


(Ron S) #17

Please don’t blow away your account. Ask them nicely to help remove the MyQ related stuff. They are very helpful.


#18

Just an update. Smartthings deleted all devices but could not delete the MyQ devices or apps. They are putting a ticket now into engineering to help out.


#19

I am having the same issue and have tried everything … it just will not delete and now it’s USELESS. I have to use the Chamberlain App to open/close my garage doors.


(Midhun) #20

Just some update. I had similar issues and I still do. But, then I ran the MyQ app from Marketplace --> SmartApps, setup a new device , which is working fine… Yes, I still got the old device and app installed… But, at this point, I don’t care. One of these days, when I call ST support, I will try to have them remove it. Hope it helps @thegalianos @mklano


(Kevin) #21

Hi, I’m running into the same problem as these other folks and can’t figure out where you mean for me to go when you say " into the SmartApp/Service Manager" to remove acceleration/contact sensors. I’m working both on the Android app and the web interface. Any more detail on this step would be appreciated.


(Kerry) #22

I have gone in circles with this topic. Can you help me delete or modify my device / smart app? I changed the name of the garage room to something else. The MyQ Garage door did not follow. I re-created the the room ‘Garage’ and tried to add the MyQ door in to it but it is not available. Right now the door is nowhere. It exists as a thing, I can operate it, etc. So I tried to delete it and start over, I experience all the same issues as this post topic mentioned. I tried deleting the SmartApps, anything that mentioned the MyQ, the device handler. Tried unplugging the MyQ interface to the web, nothing will allow me to delete this. So either 1. help to get back in room ‘garage’ , or 2. help delete to start over . Please!