Custom Device Type Save Hanging


(Rakote) #1

Is anyone else experiencing a hang when trying to save a custom device type? I tried yesterday to save something and it never saved. I then had to get to work so left it and just tried again today and it seems to just hang there forever. Am I the only one? If so it could be my code as I am trying to do local lan talk through the device type which I am not sure works with ST yet.


(Todd Wackford) #2

When things hang while saving, it usually means that there is an error while compiling. The ST IDE does not always handle this eloquently and will sometimes just appear to hang.

What I have had to do is go back into “my device types” and re-pick the file you were editing. Once it loads, try to save it again. A lot of times the error that was keeping it from compiling will appear.

NOTE!!!
A few times the IDE did not save my last edits, so when I went out and back into the file, my previous changes were gone. I have gotten into the habit of capturing the entire file on my clipboard (CTRL-A, CTRL-C) prior to getting out and going back in. Does that makes sense?

Anyway, I have noticed there are some issues with the IDE this morning. Hopefully this is a transient things and it will be back up 100% soon.

Twack


(Rakote) #3

Thanks I figured it out. was hanging due to fat fingers forgetting a close perenth and me overlooking it without enough coffee in my system.


(Todd Wackford) #4

That is a shortfall in many IDE’s. In my opinion they should sense the caffeine level in your bloodstream and react accordingly. “Are you sure you want to overwrite with only 2 cups?” Or something like that :cool:

Twack


(Jim) #5

Also noticing issues with the IDE. Its yelling at me about bad code that has been completely removed…And now I’m stuck…

uh…


(Andrew Urman) #6

Hey all

we pushed a fix for this today. Sorry about it :frowning: