CT100 Thermostat & "Keep Me Cozy" Smart App Problem


(Seth J.) #1

Guys,

I’m a noobie, just set up my first simple SmartThings network: hub, CT100, and one GE link bulb. Next step, obviously, automating the whole thing. Long story short, the light works great when I leave and approach the house. Thermostat, on the other hand, is proving to be stubborn.
I’m trying to use “Keep Me Cozy” smart app to change the settings after I am no longer in the house and then change them again when I’m back. The goal is to have “set it and forget it” system. So, when I leave the house, I set the AC settings to 85 and Heat settings to 65, and upon return AC is lowered to 77 and Heat is raised to 72. The whole system is on “AUTO” (including fan). My thinking is that during the winter it would automatically use the heat settings to approach a target temp, and during the summer it would use the AC. What I discovered is that upon leaving & return the heat settings has changed as predicted, but AC never did. Did anyone experience it on their system? Am I asking too much of this system? Any ideas how to accomplish it? Thanks for your help!


(Luke Olson) #2

I have the same thermostat.

I solved the issue by making a “keep me cozy” for each of my modes. One for home, away,and night time.

Also check out RBoy’s device type and smartapps for the ct 100. Well worth the money


(Ernie) #3

I have a CT100 and do what I think you are looking for with Hello Home actions. No smartapp required.


Two CT100 Thermostats appear to be conflicting while updating?
(Seth J.) #4

That’s the thing. I also have separate apps for each mode and the only thing changes is heating setpoint. :confused:


(Seth J.) #5

Isn’t it the same thing? ??


(Ernie) #6

Keep me cozy is a smartapp for thermostat settings only while Hello Home actions are more comprehensive. However, I don’t know if the same underlying code for thermostat settings is used. I have not had a need to use Keep Me Cozy but the Hello Home actions have worked for me.


(Seth J.) #7

Thanks alot for pointing me in the right direction! That seems to do the trick so far, at least manually. Let see if it will do it based on geofencing.
Quick question about Night action. Do you have to set it manually or is there some common automation most people prefer to use?


(Ernie) #8

I just set a time for Goodnight, but I know others will set it based on motion sensors not showing motion for some time. Additionally, a trigger that is part of a night time routine can be used. An example would be turning off bedroom lights at night.


#9

Same deal here. Except I have 3 CT100 thermostats and a total of 9 Keep Me Cozy smart apps. None of them are smart enough to actually work consistently. RBoy’s app doesn’t work consistently either.

The thermostat control when on the thermostat thing in the Smartthings app works to set the thermostat just fine, but whatever Keep Me Cozy uses doesn’t work consistently.

It would be way easier if Smartthings would let you set a unique temperature for each thermostat on a mode change, instead of just blanket forcing the same temp for all thermostats.


(Chris LeBlanc) #10

I have had ct100 thermos for over 2 years and they will only (somewhat) reliably set the setpoint if I choose only one (cooling or heating) to be set for any given action. I’ve written smart apps that delay them too and they do somewhat help the problem.

I’ve also had support reps confirm this as a known issue a couple of times and no one seems to do anything to try to fix it, engineers seem busy doing other fixes.

The ct100 is listed as a compatible device and is even sold by ST so it seems they should spend some time figuring out why it doesn’t work. It also seems like for the the most part a clearly diagnosable problem.