CSS and SmartTiles


(Dave) #1

Anyone else having issues with not being able to modify the dashboard with Custom CSS and SmartTiles? Seems like no matter what I try it seems to stay on the default color scheme. Up until this morning I was using some custom icons, colors, etc. but now it seems to have reverted back to a default color scheme.


SmartTiles v5.8: Deployed to Blue & Green Editions. Release notes, etc. (follow this Topic for updates...)
Suddenly tiles not displaying correctly in iOS 2.1.4
#2

Tagging @tgauchat


#3

My SmartTiles CSS also appears to have broken.I posted here:

I can still see that it exists, it just doesn’t seem to work anymore…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

We have not many any updates to the SmartTiles v5.8 SmartApp.

The Custom CSS is stored in the SmartApp “Application State”. You can view the current Application State of each SmartTiles instance by logging into your SmartThings IDE page and viewing “My Locations / smartapps” and clicking each SmartTiles child instance to see the details…

For my test dashboard, it is apparently being properly saved (at least at the moment…).

If the “customCSS” that you once created is missing, that is a SmartThings SmartApp state storage problem (i.e., database / platform issue) that we have zero control over. The next generation rework of SmartTiles (“V6”) no longer uses SmartApp “state” at all.


(Dave) #5

I too am able to see my custom css code… but it doesn’t seem to display on the dashboard correctly…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6
  1. Could you test a very simple dashboard with only 1 or 2 lines of Custom CSS as an example? (i.e., nothing that is Device specific, please)?

  2. Then post that Custom CSS here and I’ll see if the problem reproduces?

We have “hundreds” of people using Custom CSS and this isn’t widely reported yet, but it’s good to start somewhere!


#7

I’m pretty sure its not SmartTiles. I’ve opened a ticket with support.

Here’s Mine:

This is what it looks like currently:

This is what it used to look like (I added a few items to it last week, but the css “issue” is today):


(Dave) #8

Copy that… Well that seems to have worked. I changed out the Tile background color and title color and both of those changed…

strange…

One thing I noticed is that today if you copy over some CSS code from lets say, SmartTiles, prior to today, I would keep the “formatting” of the CSS in the custom CSS window. Now, it seems to just be saving as one Long commands separated by the \r\n …a windows line break…

here is what it looks like now…
.tile {background-color: grey}\r\n.title {color: white;}

when, prior to today’s weirdness,
.tile {background-color: grey}
.title {color: white;}


#9

Having the same issue as well.


#10

I dug a bit too.

It looks like something is doing something fun with the line breaks. as I saved, it would add more “”, until I got to the point where I noticed it now said \\\r\\n…

Without linebreaks, my code now looks like this:
/enter custom css here/.theme-onyx .ui-page.ui-page-theme-a.ui-page-active, .theme-onyx, .theme-onyx .historyNav { background-color:transparent;}

So, I guess the solution is to remove line breaks and comments from the CSS…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #11

The likelihood of it being a change or glitch on the SmartThings-side is understandably high.

Both SmartThings and us have concurred that SmartTiles v5 stretches what a “SmartApp” should be. So we’ve changed the architecture of

Unfortunately, SmartThings Support is unlikely to assist you with this problem – SmartTiles is considered to be an “uncertified SmartApp”.


#12

Funny you should mention that:

Hey Michael,

Thanks for reaching out, sorry about the trouble. I double checked the community forums and did notice a couple other people were experiencing similar issues. However, we have not had any problems or issues here on our end that would have caused this recently.

I would definitely try reaching out to SmartTiles to see if they are able to help you get this all straightened out. You can find the contact information here: http://www.smarttiles.click/support/.

If you have questions in the future, don’t hesitate to reach out!

Kind regards,

I’ve asked if something that parses text or comments has changed, but we shall see. With each week, and each new “feature” that no longer works correctly with SmartThings, I’m looking forward to any opportunities to isolate the platform from itself.


#13

Same thing here. My CSS seems to be all run together and is apparently useless. Different problem than last time but, same effect. This is getting old. Is this what happens when the programmers are unpaid interns.


(Don) #14

Add me to the list of unlucky souls to have messed up CSS. I tried deleting it and copying back from my backup. It just messes it up again. Bummer. I had just tweaked on it some this past weekend.


(Megan) #15

I posted in the other thread, CSS broken for me too


(Alex) #16

This must the the cause of this. Somehow line breaks got encoded into \r\n…[quote=“tgauchat, post:11, topic:56006”]
SmartTiles is considered to be an “uncertified SmartApp”.
[/quote]

I thought we are certified!?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #17

Not according to every Support@SmartThings.com ticket that users relay to us.

I have no idea what the difference is, except we’re not supposed to talk about it.


(George) #18

:laughing: :sweat: :cry:


(Barton.) #19

Following the CSS wipe a few weeks back, I haven’t bothered resetting up my system to the way it used to look. Now, however, I’m always being forced to log back in, which makes a tablet on the wall useless. I use Fully, and it has always worked until a week and a half or so.


(Alex) #20

If I had a dollar every time someone said this, I would be rich!

@slagle This is #101