Cree Bulb and Smart Lighting SmartApp

smartlighting
cree

(Darrell Gibson) #1

I have a Smart Things Hub v2. I also have a Cree Connect bulb. I can add the bulb to the app and control it. On, off, and dimming all work. If I add it to the Smart Lights app it goes sideways. When I wake up the light is not communicating in the app. I have to remove it and re-connect it to the app.

For the smart app I have it turn on at sunset. I set it to 10%. I add 3 min to the sunset and sun rise.

What can I do to get this to work? I did a quick search, a real quick search. I have to admit my google-fu is lacking.

Thanks in advance,
Darrell


#2

Darrell,

Is this the only ZigBee device you have? How far is it from the hub?

I currently have 13 of these and they have been very reliable for me. Including those using the Smart Lights app.


(Darrell Gibson) #3

It is the only one. It is in the upstairs hall with the hub in the living room. I would say it is about 25 feet away.


#4

It’s possible distance is the problem although from you initial post you seem to indicate you can always control the bulb via the app.

Two things I can think of to try.

First move the bulb to an outlet closer to the hub. Just for an experiment, to see if the automation will trigger the light the next time it runs. I would try this one first.

Second, delete and rebuild your Smart Lights Automation just to make sure you didn’t accidentally put in some kind of restriction that is causing the automation not to run.

if the first experiment solves your problem you will know you have a distance issue. Remember that walls and other obstructions reduce the effective range of the hubs signal and you have no repeaters for it to use to convey the command to the bulb. Your choices at that point will be to move the hub, or install additional ZigBee devices to help relay hub commands to the bulb.


(Darrell Gibson) #5

I have moved it downstairs and it works. I setup a trial smart light routine and it worked. I am going to buy a second ZigBee bulb to test a larger mesh network.

Thanks for all the pointers.


#6

One other thing. When you have the 2nd zigbee bulb paired and placed when you want it. Take your hub off power and remove the batteries. Let it sit that way for about 20 minutes. This is the only way to make zigbee devices look for alternate routes. It’s like a z-wave repair but for zigbee devices.


(Darrell Gibson) #7

Okay, I have another real quick question. I can get the light to turn on with the Smart Lights app. It all works well. When I pick sunset/rise as the trigger it does not work. I have noticed that the time zone is not filled out in the hub settings. I cannot get the time zone setting to fill out. The coordinates are correct for location. I think if I get this filled out maybe the sunset/rise trigger will work. Any suggestions on how to get this filled out?

Thanks again


#8

I agree with you that fixing that will probably make the automation trigger. I’m sorry, I’m not sure what you need to do to get that fixed. Perhaps someone else will add to this thread that can advise you. My best suggestion would be to reach out to support.

https://support.smartthings.com/hc/en-us

If you look at the bottom of the page above you will see the methods for reaching them.