Cost effective door/window sensors (UK)

So I did it just in case, but no joy.
Stripped the batteries out and went out for an hour or so. Came back and everything came back online OK. Re-added the two erroneous sensors and both were picked up instantly, but nada - both are showing OPEN and do not respond when the magnet is in contact or nearby.
I’ve even tried using the magnet from the one that is working, but the sensor(s) still do not respond.

The following is the checklist for when an individual sensor is stuck… You probably already tried all of these things, and they don’t usually apply when it’s more than one sensor, but just for completeness here’s the checklist:

If it was just one sensor, I’d probably just assume it was a bad device and return it. It happens. Some estimates are that about 15% of inexpensive electronics are DOA.

My concern is that you’re now seeing the problem on more than one sensor. That’s much more likely to be a network issue, either interference or range.

Just to be sure… Is your smartthings hub at least 3 m from your Wi-Fi router? Just looking for local interference possibilities.

Also, look on the devices themselves and check that the model number is right.

Thanks for the link. Lots of useful information in there.
Changing batteries is one of the first thing I did, replacing the included one with Duracell’s to be sure. In fact, a brand new Duracell is in one of the ones that isn’t working now as I type.
I’ve checked the model on all three and its the same, SM102W

My hub and router are <3m apart. Probably closer to 2m as thats the longest Ethernet cable I have. All other devices are working fine though…

So, are you saying that even when you bring the sensor close to the hub and bring the magnet close that the green light sites not come on?
When you reset the device have you performed the below?

  • Delete the device from the system
  • Hold the button down until the light rapid flashes.
  • Add thing in app
  • Press the green button until slow flashes
  • Then when discovered light goes off
  • add to device to a room

Before taking the device away bring the magnet close. Does the green light come on?
Lastly have you looked at the logs and seen if any errors are coming up for the device?

1 Like

@a4refillpad Yep, thats pretty much the process end-to-end and no, nothing. I’ve put the sensor within a few inches of the hub and it behaves exactly the same.

Just in case it was a battery issue I bought more from Amazon and had them delivered this morning. Tested with a brand new Duracell battery and exactly the same result, so I think we can rule out battery problems.

Device powers up, its picked up in the app immediately but even though the magnet is physically on the sensor in the right location, it is picked up with an OPEN status, whereas obviously this should be CLOSED.

Even thoughj the sensor is a few inches away from the hub, moving the magnet to and from the sensor does nothing, no LED flash or anything. I’ve tried the magnet from the working sensor too and that doesn’t cause any response

In terms of checking the logs, do you mean the list of events in the events list under my-devices for the selected device? If so, I’ve just gone through the process decribed above again and the event list is empty. Same for the other one which hasn’t been removed for a number of hours now.

Doesn’t sound good. I was talking about the events in the live logging in the IDE.
You should see events listed for the device added. If not then the device is not adding to the system properly. If you do get events then there’s another problem.

OK, must have been a browser caching issue as I’m seeing events in there now:

Orvibo Contact Sensor (Device) Events — displayed | all | from device
Date Source Type Name Value User Displayed Text Changed
2016-07-10 12:08:41.283 PM BST
5 hours ago DEVICE ENTITY_UPDATE DeviceUpdated false
2016-07-10 12:08:28.939 PM BST
5 hours ago DEVICE ENTITY_UPDATE DeviceCreated false

Nothing in the live logging section as I move the magnet to and from the sensor

Sorry looks like it’s dead Jim. Even if you don’t have the correct DH loaded the contact should generate raw events.

Still haven’t been able to get two of these to work. In the end I went back to BangGood about the issue and their customer service was fantastic. Asked me to upload a video of the working and faulty units so they could see the difference and once I did that they issued an immediate refund for the faulty units.
I’m in two minds now whether to order more given my experience and the reliability (could just have been unlucky I know), but their customer service was excellent. Just wanted to post an update for anyone thinking of ordering from these guys.

1 Like

I have 27 of these and not experienced any showing the behaviour you described. You must be either very unlucky or I’ve been very fortunate!

1 Like

I’ve not got as many as @a4refillpad, but I’ve got 10 and also haven’t had any problems with them. Very pleased with all of them, for the price they are excellent.

Maybe you have just been very unlucky.

1 Like

Yep,I’m going with a bad batch and unlucky timing on my part. I’ve ordered one more given their excellent customer service, so provided that one works I’ll invest in a few more after that…

Fingers crossed

1 Like

@leedjones long shot here.

I’ve had some more of these turn up today. I’ve got about ten to date and I’m likely to get more as I start to add them to legacy smoke detectors (I also have one hooked up to my door bell). Anyway…

I’ve unboxed a couple of them and added them and it was anything but straightforward (compared to normal). I set my phone looking for new Things and inserted the battery. Nothing! After much messing around and resetting the Orvibo sensor I noticed that the device had been added in the IDE. I’ve just killed the app and I can now see the Sensor and it adds as normal. As detailed above don’t forget to add it to a room.

Probably won’t make a blind bit of difference but thought it might be worth a shot.

@brumster I’ve added a lot of these now with my DH and they all appear fine on discovery as “Orvibo Contact Sensor” does it not appear for you? Do you then subsequently change the DH manually? If so then it sounds like maybe the fingerprint has changed for a newer batch?
Also, please share how you’ve hooked up the orvibos to your doorbell. (Preferably with pictures!)

@a4refillpad if it’s your DH then I should start by saying thanks. At £13 or £14 quid they’re ideal, they look good and you’re saving me a fortune :slight_smile:

As per usual I’m probably not making myself clear. I was adding the device via an iPhone but ST just wasn’t finding it (or at least not reporting that it was). After resetting the sensor a couple of times and trying to add it I eventually went into the IDE and there it was! Sure enough I then checked the device list on the phone and it was there??? I have to confess I was confused at this point. I then killed the app, added another sensor and all worked as expected. Fingerprint was correct. Looks like an issue with ST, nothing to do your with your code.

I just thought it might be a possible answer for @leedjones as I’m surprised like you that he may may have received multiple duff sensors from BangGood. I’ve got 10+ and they’re working well. They’re so cheap I’m automating for the sake of it…

As for the Door Bell I used the notes from this thread:

I popped the case of an Orvibo contact sensor and soldered a couple of wires across the sensor (it’s black from memory). I then hooked it up to a ten quid door bell from Amazon. I’ll snap a picture later for you.

This also popped up yesterday:

1 Like

A heads up for the Sensative strips, they’re on sale at Vesternet again, a touch under £40.


I’ve got one of these already and they’re fantastic.
Hopefully Texecom will get back to me today about if Z-Wave devices can be incorporated into their alarm system. If so, i’ll pick up another one today as they’re hidden

Sorely tempted by these. Does anyone have any experience using these on metal gates? I’ve had no success with the standard ST multi function.

I doubt they’d work to be honest, I reckon that either the metal would interfere with the magnetic or restrict the signal strength.

Had some uninvited guests open the gates overnight and enter. Can’t get a solution which is reliable right now. Cameras and motion sensors just false alarm all day long.
Thought I read somewhere that these were suitable even for windows with metal frames. But could have imagined it! :slight_smile: