Corrupt DTH Making all Devices Inaccessable

Problem: Error 500: Internal Server Error appears on most screens when accessing my account via the API. And viewing devices via the app displays “Something’s Wrong”.

I have tried accessing the devices via api from the main devices link, the location page, the hub page and others. But all pages display the 500 Error. I also tried opening the page in a new browser, safe mode, or even a new laptop. None worked.

I have been able to use other devices, which are assigned to rooms. As long as the corrupted lock is not assigned to the same room, those devices can be shown. So I know it’s this lock which i causing all of my issues.

Background: I was having an issue with a zigbee Yale Lock, and I made a small change to the device handler. This change somehow corrupted the lock and caused an error to appear on any view that the lock appears in.

I know the direct URL for the corrupted lock, and i can view it. But if I click Save it goes to the 500 Error again. So I have no way to change the DTH on this lock or even delete the entire devices from SmartThings.

I opened a support ticket on Friday (2/1), but I have not gotten any replies yet. I called the support phone number, but was placed on hold for an hour until i had to hang up and go back to work.

If the answer is that I have to delete my account and start again, I will be done with SmartThings and just move over to Home Assistant at this point…

You’ve probably tried this - but have you tried pasting a “fresh” DTH over the one the lock is associated with? (I’m sure you have, but - I didn’t see it listed). I miss the days when someone at SmartThings would get on chat with you almost instantly and do the necessary delete. Good luck!

1 Like

when using the IDE, use an incognito window.


I stupidly deleted the problem DTH :frowning: . When i tried to edit it, i got the same Error 500.

Thanks. I have tried that and still get the same error. Unfortunately this is not a case of local cached items.

Well I sat on hold for another hour until I finally got someone from SmartThings support.

After explaining the problem, the L1 Support wasn’t too sure what was going on, but agreed that “it looks like a problem with the I-E-D”.

So now I am waiting for L2 support to respond in 24-48 working hours. I am also on the lookout for any improvised explosive devices attached to my smart home.

this doesn’t inspire confidence that support will ever figure it out…

:bomb::exploding_head: :joy:

Unfortunately, Samsung has outsourced Level 1 support (or so I have been led to believe). I presume that they can’t provide help for anything more than just screening calls and suggesting reboots or, gawdforbid, hard resets & rebuilds.

You should be good to go now.


hallelujah!!! That’s is amazing!

Can I buy you a coffee or beer? I seriously appreciate it.

Was there anything that I could have done to fix this on my own?


No, I don’t think so. You were experiencing the same thing as this: FIXED: SmartThings Server Error (it was me)

Identifying and deleting the device record can be a bit involved, though you made it easy by identifying the device for us.

1 Like

I have the same thing as well I think. I was in the process of trying to add an Iris keypad using RBoy DH. I have two tickets open now #19020600507 and #19020800306. Does knowing that I think the Iris keypad install was at the root of the issue help to resolve the issue? I changed the “name” in the definition line in the device handler from “Enhanced ZigBee Keypad Lock” to “Z-Wave Lock”.

It was the Iris keypad and it’s fixed.

Thank you, I’m all set now!! How is everyone getting in this situation and how do we prevent it from reoccurring? Do we stop attempting to integrate the IRIS keypad?