Constant nagging about "enable Bluetooth" everytime I open the new iOS app

Whenever I open the new Samsung SmartThings app (not the classic app), I always need to dismiss a message about enabling Bluetooth in order to discover new devices. I never need to use Bluetooth and I always keep it disabled. I assumed after the first time I dismiss the message, it would never nag me again unless I uninstall and re-install the app. However, this is not the case. I always get the same message about enabling Bluetooth, even if I deliberately disable it via the iOS Settings for SmartThings.

Is there a way to permanently get rid of this message?


DISCLAIMER: I am a new member and I rarely use online forums or message boards. I try my best to research information and answers online first, yet some things are difficult to come by due to the ambiguity of web searches and the mismatch of “natural language” against technical terms. I am neither a developer nor engineer, yet I do consider myself fairly tech-savvy. When it comes to SmartThings, I feel quite lost, so I decided to elicit the aid of the community to understand more on “how things work” and to discover solutions to my issues and concerns. You might notice a sudden flood of new topics that I create. The reason for this is because I would prefer to keep unrelated issues and questions separate. Go easy on me. :slight_smile:

Yes:

  1. Just Never open the Samsung Connect App - heck, you can uninstall it. Use SmartThings (Classic) instead. It should do everything you need.

  2. and/or: Contact SmartThings Support. They need to know of problems like this and will give you the solution to such a basic question.

https://support.smartthings.com/hc/en-us

1 Like

I have already tried using the Classic App, but there are a few problems I’ve faced already.

1.) Eventually Samsung is going to discontinue it, so I figured I might as well get acquainted, rather than create routines, rooms, scenes, and automations, which may not gracefully transfer over to the New App.

2.) I cannot create custom automations with the Classic App. When I create a new Routine, if I choose to have it automatically trigger based on a certain parameter, I can only slect from a list of presets. One enormous option lacking is to trigger it based off of my Ecobee Thermostat’s relative humidity reading. With the New App, I simply click “custom” and build the automation to my liking, and I can even bundle multiple triggers that must all be “true” in order for the automation to execute. With the Classic App, there is a “SmartApp” (more on that in another thread, because the terms SmartApp, Connected Services, Device Type Handlers, etc, seem to overlap and criss-cross), which allows me to do something similar, yet only with temperature, not with humidity. :confused:

3.) It still suffers some interface design flaws that keep throwing me off. I found no way to remove the “SmartMonitoring” tile from the main dashboard, which I’m not using, and it looks like a pointless advertisement box. It serves no function for me other than to remind me “Hey! You can setup alerts!” With buttons and switches, I have to be careful on the main dashboard favorites to either long-press or tap. Since it’s a single button, I have accidentally turned off a device because I didn’t hold my finger down long enough. With the New App, there is plenty of space between the device’s name and its toggle button. This is a much more intuitive design.

I have been back and forth with Samsung/SmartThings support, and it’s a bit like pulling teeth. I’m not upset with them, but it’s a roll of the dice, depending which person I get. I had to wait several days because my new V3 hub would not register, no matter what steps I tried, even with support on the phone. They never called me back, which they promised. So I finally called them again, and this time I got a different agent who was more familiar with troubleshooting this problem, and within minutes we got up and running and my hub registered correctly on their servers.

1 Like

In Classic, Smart Home Monitor is implemented via a SmartApp, which you can uninstall using the SmartThings IDE (https://account.SmartThings.com).


Yes - Indeed the new App has pros and cons, and I expect, over time, the pros will definitely outweigh the cons; particularly since there is a goal of some degree of feature parity with Classic.

How do I uninstall it?

Using the IDE, under “My SmartApps” I see this:

You don’t have any apps yet. Add one now.

That’s the wrong Tab (but understandable). “My SmartApps” is where your custom SmartApp Groovy code is stored (ready for installation or just ad hoc development). Most customers will never use this Tab. But this is where you install stuff like webCoRE, etc…

  • To find your actual Installed SmartApp instances see the “My Locations” tab.
  • Select smartapps next to your Location
  • Select Edit to put yourself in the mode in which you can find and delete Smart Home Monitor (if you really want to do that :wink:).

Awesome! That did the trick! Thank you so much, @tgauchat.

Now I am even more confused after doing some reading on these forums and browsing the official documentation. For one, where did those “smartapps” even originate? How would I even be able to modify or edit them? I’ve played around and added a third-party Weather Underground “smartapp”, which I see under the “My SmartApps” tab, of which I can modify, save, and publish (to myself.) Therefor, it’s clear to me where I would go to edit such a smartapp. However, the pre-packaged ones under my home location, I am unsure. It’s as if they exist in the ether.

I prefer not to create cluttered, inter-connected posts, so I’m going to later on create new threads specific to the other issues and confusions.

Thank you again, kind sir!

1 Like

Some of the pre-packaged ones are in SmartThings’s public GitHub and others are closed source / proprietary. Some, like ActionTiles are 3rd party and closed source, but published by SmartThings via partner agreement.

The Community has shared tons of SmartApps in source code for for pasting into My SmartApps (or GitHub linking for some).

But this style of SmartApps (aka “the Groovy API/IDE”) is eventually deprecated. New API (beta) is available, but not much has been done by developers with it yet.