Clue to Duplicate Hue lights in new app

I think I have a clue as to why we are seeing duplicate hue bulbs in the new app. I took a look in the IDE to get rid of the dupes, and I saw this:

It looks like SmartThings is misinterpreting the Hue v2 hubs ability to work offline. To do that, states are maintained on the local Hue v2 hub and are constantly updating with the Hue cloud when available.

I think that SmartThings is seeing the index of devices from both the hub and the cloud, and displaying them both as devices. (@blake.arnold I suspect this is why both the device and the “ghost” device operate correctly on the device - one is local, one is cloud, and both are informing each other of each other’s state.)

I’m not sure if this is relevant or not, but there are two ways to connect to Hue in the new app.

If and only if you have a hub you can connect to the Hue bridge locally by LAN. This would’ve been the connection you would have had with the classic app.

You also have the option to connect cloud cloud, which is intended for people running smartthings in a “hub optional“ configuration, for example, if they only had a Samsung smart television and a hue bridge. This appears under “Linked Services.” Tap on the 3 horizontal line icon in the upper left, then choose The gear icon in the upper right, and you should see “linked services.“ Select that, and if you see Hue there, then you are using the cloud cloud integration. I don’t have my Hue bridge connected in this way, but you can see here where it would appear.

It is possible to make both connections, in which case you would see what you have described in your post. Some people have done that in the past when they were moving things over manually. The fix for those was just to unlink the cloud connection while retaining the LAN connection.

It may be that the migration utility got confused and ended up connecting people both ways, or people may have inadvertently added the second way not realizing they already had the first.

But I just wanted to mention that because I think Hue is the only partner at this point which can be added both ways.

1 Like

RUT ROH looks like someone still has the old meross integration in their linked services :slight_smile:


My only techie aide comes on Tuesdays. it will have to wait until then. :wink:


This is your problem. Remove the cloud integration from linked services menu.


@Automated_House saying it is “our problem” isn’t helpful. This is the result of the Classic->New app migration. No one did this on purpose.

OK - so I removed the cloud integration from linked services, and I am still getting double devices on the Hue lights. Cleared the cache on the app, etc.

Also, they still show up as doubles in the ST IDE.

1 Like

It’s possible it may take 24 hours for the cloud version placeholders to be cleared from your smartthings account. It’s not instantaneous, there’s some kind of periodic update.

1 Like

OK, thanks JD

1 Like

I’ve never heard of anyone having an integration automatically added during migration. Especially one that would require you to type in login credentials.

And yet, it did. It migrated IFTTT, LIFX, Accuweather and Hue all on it’s lonesome. Google and Alexa I had to do manually.

The Hue migration was the oddest. Clicking on Hue on the “Linked Services” page revealed a blank screen… LIFX, Accuweather and take me to the control pages…Hue just a big blank screen

Possible if you clicked on + devices, hue and opened it, even if you didn’t login and exited, that it would create that blank screen. I am always testing integrations and I get them all the time :slight_smile:

Also, the migration tool does not migrate Smartapps or devices. Those are already available in both apps, before and after migration.

Migration only touches shm and shm custom rules, routines and smart locks in the Classic app.

But weirder things have happened to some folks after migration so who knows… maybe you got lucky and got the new hue integration.

Thanks for this - I only clicked on +, devices, hue recently when I tried to figure out what was happening – but that didn’t cause the migrations.

Your second point is the culpret: yes, you’re correct. Since the integration occurs on the server-side, not the client, that’s why those migrations were “waiting for me.” I didn’t do them, they didn’t migrate, they were already in place in my account on the main servers for ST.

If you read some of my other posts, a few other odd things happened: it migrated the scenes for me, but left them in a bizarre state: They work, and are functional, but they cannot be edited in any way. One by one I’ve been deleting the scenes from the IDE then recreating them in the new app.

Editing of Scenes are disabled on the Classic app. Are they not editable in the new app too?

1 Like

They were not for me, it would let me edit but when I tried to save it I would get a “network error, try again later” message.

Yes, that has occurred with others. I wish I had an answer on that one. Most do what you have done… delete and recreate. Painful and frustrating.

For those that haven’t seen it, and want to throw up in your mouth a little:


And be sure to report all the issues to ST support. Hey… you might get a good laugh at the response they send.

They are aware :wink:

1 Like

Isn’t that just hitting one of the pointless guard rails?

1 Like