When scanning for nearby devices, all Hue bulbs get re-added, and duplicated

When using the scan nearby feature, I notice that all hue color bulbs get re-added; duplicating them. Does anyone know a way around this? Or a way to prevent them from duplicating?

When I log into the Smartthings IDE I can see one of them has a type of “placeholder” I was told that is due to the migration. The other device that is already present is the “LAN Hue Extended Color”. I did have all of the LAN Hue Extended Color ones removed, but the last time I hit “Scan Nearby” for a new edge driver I had installed, they all re-added.

Thanks again!

One is the cloud-to-cloud integration which has the placeholder in IDE. The other is the direct LAN connection which is the LAN Hue Extended.

There are two options when you go to Add Devices and select Hue. At some point, you likely selected the other option so you ended up with both.

Go to menu > settings > linked services to remove the cloud-to-cloud integration if you want to remove that one.

If you wish to remove the direct LAN connection, remove the hue bridge which is listed in Devices > All devices

Thanks for this. I am seeing mixed reviews on which ones is better. Is there a recommendation on the better option here?

The cloud-to-cloud option is mostly used by those without hubs. There is one item it offers that is not currently available in the direct connection → Hue outdoor motion sensor.

My recommendation would be to use the Direct LAN connection. It will be switched over to Edge at some point but I don’t believe that process has begun yet (for Hue).

1 Like

I think there are pros and cons to each.

If you add straight to the hub, I believe commands are processed locally?

I had mine on the hub and just got the message that I’m running low on memory, so I switched to the cloud connection. It was a pain to go through and update automations and such but I freed up 50+ devices from my hub.

I also read that having hue on the hub can cause interference with other zigbee devices.

Thank you for that explanation!

Oh thats interesting! I do have about 30 bulbs, and still adding more :frowning: I am very close to 200 smart devices. They add up very quickly!!!

that is only if you connect the lights directly to the hub. The direct LAN connection is the Hue Bridge that is connected so their lights are still separate so there would be no interference.

Oh ok that’s good to know. Thanks.

And now as Hue bridge is Matter certified you can add all the lamps a third time.
Just to make things even more confusing :crazy_face:

1 Like

So I am trying to just add my lights via the LAN, when i select the actual bulb under add device, it is bringing me into Philips hue to sign in. I think when I did this last time, that is when they all popped up.

The only way to add a hue light directly to a ST hub would be to remove it from your hue bridge first. I highly recommend against doing this.

with your current situation, I recommend go to Menu > Settings > Linked services and removing the cloud-to-cloud integration. That will get rid of the duplicates.

That will leave you with the direct connection between the ST hub and Hue Bridge which is the best way to use your Hue lights.

Ok, so I thought i did that, i went to the linked services and clicked on the Philips Hue and removed that. The duplicates did go away.

But now i am trying to add a light, and when i go into add device it wants me to connect to philips hue. If i do that, it will do the same thing.

Do i need to go into philips hue, and add the light there?

Yes, add the light to your Hue bridge and it should show up in ST. If not, tap Add Device and then tap scan

1 Like