Classic App will not connect, issues with your network

Starting today, 4/27, my classic app will not connect to my hub. It states that I have an issue with my network. Light on hub is green, everything else with the hub is working perfectly, including the remote, google assistant and all automations. Restarted phone, app and hub. Everything else on my network is working perfectly. New app connects fine.

Done and done. Restarted phone. Did not help.

if android, try clearing the app cache. or remove/reinstall the app. last resort - contact ST support

1 Like

Where are you seeing the error and what steps are you taking leading up to that error?

Your phone doesn’t connect directly to your hub. If the hub’s LED is green and the new app and IDE indicate things are ok, it sounds like an app issue. Android or iOS?

I am now having this same issue, tried on cell connection, cleared cache and force stopped the app, new app does work and hub reports online etc through IDE, has green LED.

I’m on android, app version 2.19.1

Where does the error display? I’m still not clear on what steps are leading up to the error showing.

@Brad_ST upon opening the classic app it does not load at all. I get the following error message on either WiFi or cell connection;

From there I X out of the red notification and the screen will just sit at this;

This morning there was a new error message though;

Like I said, cleared cache, restarted phone, on a known working connection, hub is online, new app seemingly works fine.

I had the exact same “problem with your network” zero connectivity problem start yesterday and continued into today. I’m using Android on Pixel 4. I noticed my kid’s iPhone still had SmartThings Classic app connectivity. There was no fix clearing cache, changing networks, force stop or reboot etc. The ONLY thing that worked was force stop, clear cache, uninstall, reinstall the app.

The newer ST app didn’t have this problem, just Classic.

Before I go that route, will that clear out routines that I am still using? In the classic app I have seen people lose access to them doing various things.

PS. classic app is still not working, only thing I havent done at this point is un-install and re-install but I am very hesitant to do that.

There isn’t a risk involved in removing and re-adding the Classic app.

Do you have a recent timestamp for when you saw this issue? I looked in the logs based on your screenshots but wasn’t able to find the error. Do you have an open support ticket?

Will attempt a re-install of the app in that case. As far as timestamp goes it happens every time I log in. Cant actually get into the app so it has been just sitting there, me trying to see if it works every few days or so. Also I do not have a support ticket, I will try a re-install of the app and if that doesnt fix it report it and come back here with a ticket #. Thanks.

Uninstalled the classic app and re-installed, appears to be working again.

1 Like

Same thing happened to me yesterday. But on another phone, it still works. I decided to switch to the new app on the non-working one. There is still a lot of learning to do.

I’m getting same issues as listed above, also 7 series tv smartthings app now says samsung server is down for maintenance which is a different message from yesterday which said server unavailable

@Brad_ST As of this morning back to the same issue again for me. Going to try reinstall again but this is getting frustrating.

Can you open a support ticket and try to get a timestamp of a time you experienced this issue?

It has to do with being logged in to the classic app on multiple devices. Even though the error message doesn’t indicate that. I tried to login to classic on my new tablet but it wanted me to do two step verification and I won’t have a phone until tomorrow. However, that failed login attempt on the new tablet seems to have been enough to cause the same error on my old tablet. Now I can’t login to Smartthings at all until I get my phone because I can’t uninstall/reinstall on my old tablet due to two step verification…