Classic App Removed Routines?

Routines no longer show up in the classic app if there are none installed, which means your can’t add any either. If there is already at least one routine then it is still there.

On the same subject, were’t routines imported into GH at one point? Did that integration go away?

All of mine are still there.

Yes, but if you remove them there is no way to add them back without an older apk, once the routines section is empty it goes away.

1 Like

Routines are NOT being migrated into the new app. They are being replaced with scenes and the custom automation creator.

I am beginning to think the sunset of the classic app may be coming sooner than later. :thinking:

1 Like

You should contact ST support and ask them to add it back for you. https://support.smartthings.com

2 Likes

For some reason I read the quoted part above as “If there is already at least one routine then is it still there?” I thought your were asking a question.

This was a good reminder for me to clean up my Routines in the Classic app. It had become a graveyard of unused snippets.

I can confirm. Once you delete your last Routine, the tab for Routines on the Automations page disappears.

I restarted the app, not sure that was necessary…

Honest question: if you don’t have any routines in Classic at this point, why even start now?

2 Likes

Exactly. As soon as I replicated my last Routine in the new app as a scene (or automation), and validated it worked, I deleted it from Classic. As soon as I did that, Routines and the ability to add any more in Classic were gone. Like you said - why even start now…

2 Likes

I had the newer version 2.18x of the SmartThings Classic android app loaded when I lost the Routines section too after deleting my last Classic app routine during migration to the new Connect app. I was reading some other SmartThings forums about the ‘fiasco’ with some other things that users were experiencing with the new 2.18x version. So, I thought what the heck, and removed the 2.18x version and downloaded the SmartThings version 2.17 from apkmirror and loaded it. NOW my Routines TAB is BACK!!! I then created a dummy (blank) routine and then went to the Google Play store and updated SmartThings Classic to 2.18x, and the Routines TAB is still there in the latest version Classic app.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.