Changing a device's group?

Does anyone know how to change the group a device is in?

I can’t find any method on the Android app, and editing the device from the website silently ignores the change after you click update. Seriously, I edit the device, change the group, click update, the device is still in the old group.

Any ideas?

1 Like

Sometimes you need to stop the mobile app and restart it for changes made in the IDE to show up. The other way to do it in the mobile app is to go the room (group) it’s in, edit that room and remove the device from that room. Then go to the room you want it to be in, edit that room, and add the device to the room.

1 Like


Yeah, losing that functionality in the IDE drives me nuts, and has been another ding in the app/hub 2.0 experience for me…

Anyway, in the app, first Edit the Room, remove the device, and then go to the other room and add it there.

1 Like


Thanks. I didn’t think to try and edit the “room”. For some reason it seemed like I’d have to edit the device itself, and change the selection there, but that’s obviously not the case.

@srpape, it does make sense that you should be able to do it from the device as well, doesn’t it? Add this to the list of future improvements.


You can in the IDE it still called a group there, but basically the old groups are now rooms. > My Devices > (Choose a device) > Edit… the very last option is group… change it :smile:

@sidjohn1 Try it, you can’t. It use to work, but it doesn’t any more. I saw your post just now and it still doesn’t work. I’m quite familiar with the IDE.

1 Like

damn your right… it doesn’t stick :frowning:

1 Like

Ya, it stopped working within the past day or two at most. I’m certain it worked over the weekend.

@bravenel, trust me on this one - even longer than that. I included this issue in another open ticket I have. I think it’s been a problem for over 2 weeks.

1 Like

Man, there are so many of these little things they mess up, too many to keep track of. Plus, they only sometimes mention that something is fixed. Not a lot of discipline on display, but there is a lot of movement forward on display. Overall, kudos to ST for how they’ve progressed recently.

Yeah, I can only imagine the firefighting going on since initial release.

1 Like

Here is another bug. Try changing the Icon of a device in “Edit Device”. It doesn’t stick.

This isn’t true for all devices, but it is true for all dimmers.

Still not fix yet :frowning: Now the android app is showing double of everything sometimes. Things are NOT getting better. I see more and more issues.

:evergreen_tree: End of Year Status:

Android FIXED

Change Group/Room in ST API

Also of note, you can not change the order of devices in a room edit in the app. It moves, but does not save.

One out of three ain’t bad :grimacing: