CentraLite Keypads

Click the gear in upper right corner. Offset field should show

Yes it does but can’t get a minus to show.

Even tried my wife’s phone and the minus is missing. I think this is missing in code.
value = v - offset

Tried adding this to code, no luck. Not like other DTH where you get an option. Maybe Mitch will see this.

It works fine on my Android. Just checked it. :slight_smile: Maybe try an Android device?

You may have more luck with the newer version of the device handler that @zcorneli released, there’s a link to that DTH’s thread earlier in this thread.

I updated my original DTH that Mitch developed to the newer one when I started using @arnb’s SHM delay smartapp.

The newer version of the device handler also doesnt seem to have an option for negative temp offset, on iOS at least (I just checked my own). But you’re more likely to get a response in that thread. His profile page says Mitch hasn’t been to this forum in like a year.

I didn’t realize I am using that DTH, so I have posted there also. I never needed the offset for this until now.

Works properly in Android.
By any chance does this work?

Yeah I thought about something like that actually, but that lower left key is just blank in the iOS app. See screenshot.

No the flyout menu only has the comma and period. This is annoying.

It seems this is something that has to be changed in the IOS SmartThings app.

Yes I am hoping the DTH can be changed.

Just curious if anyone has found a more secure way to mount the keypad to the wall ? How it’s done now anyone could simply walk off with it.

I have two keypads, they’re both inside my home.

If someone I don’t know can take the keypads off the wall, I’ve got bigger problems at that point than the keypads being carried away.


Since they have set my alarm off, police will be on their way and been recorded on at least 4 cameras by then, they can have it if they want it that bad. LOL


What is the trick to getting ST to add the keypad? I’ve added the Device Handler from farther up, and the one of the Keypad apps, but the ‘Add a Thing’ is simply not finding the keypad to be added. I have a ton of z-wave components but this is my first Zigbee, is there anything different about adding a zigbee?

If the keypad is not getting a good signal from the hub you may need a zigbee repeater. Try moving it closer to the hub to get it to connect.

Not sure what you are using, but suggest the following:

First install this DTH

Then follow info at this link

After it’s installed, you need an app to make it useable with ST and SHM. I shamelessly suggest my app SHM Delay Version 2


Updated the Handler, actually already had SHM (v1) so updated to the newer version 2.

Still no joy. The process I am following is the same as I’ve used to add a Z-wave devices in the app, open the Things list, click + Add a Thing, press a button on the thing until it registers. Only with the keypad it is not registering. Also attempted to manually add the device in the API buy using the long UID string on the Keypad as both the Zigbee ID and the Device ID. Neither approach seemed to work, what am I doing wrong?

The keypad is sitting about 3 ft from the ST hub.

On a different topic, I setup your delay app for the two doors that would need a delay if the keypad was working, but I am not seeing anywhere in either SHM or SHM Delay that allows me to add User Profiles for what pin is used to arm/disarm. Where do I find that?

The Keypad can sometimes be a pain to get connected and is a two step process. I’m out of ideas other than to reset the keypad back to factory settings, then retry according to the directions in Zack Cornelius’ post. BTW is this keypad manufactured by Centralite?

Set Global “Activate Total Keypad Control” to ON/True

can someone help me. I am having a very hard time getting the Centralite xfinity keypad into pairing mode. I tried the process of holding tamper and then inserting one battery, then release tamper about 2 seconds in but for the life of me I can get it to blink so its in pairing mode…am I missing something? I have tried over 100 times.