CentraLite Keypads

Android screenshot of error

That info is currently out of date. An updated Device handler and Smartapp selection is available in the new thread, here:

The major problem you’re running into there is that you need to pair the device through the mobile app, and not through the IDE. The newer DTH and SmartApps though are a bit more reliable (Especially with respect to the pairing process), and feature filled. There’s a set of instructions in the first post of the new thread.


Ahhh thanks so much, installed new code and it instantly started to connect.

Only issue I’m having now is with Smart Alarm, it’s telling me I can’t select a camera to record even thoughI have the Samsung Smart CamPro which is already paired with the hub?

How are you guys mounting this? Has anyone come up with a creative way of getting it to sit flush with the wall?

Could you please help me. I am having a lot of trouble setting up my iris keypad. New to smartthings but have basic ida of what I’m supposed to do. I applied the handler and smart app but it keeps coming up as a thing and can’t do anything with it. Could you help me fix this?

If you haven’t done so already, check out the updated thread here: [RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

Hello I tryed the DTH and the smartapp and they both failed Am I doing something wrong

Can you please tell me where I get the device handler?

Should have everything you need here from handler to smartapps. I personally use CoRE fro my entry delay.

Is there a fix for the battery drain issue?

I have 2 both sets of batteries are over a 6 months one may he a year. One is 77% other 100%

Sadly, the fix for the battery drain issue on the Iris keypads is:

Get or find someone with an Iris hub v2, and pair the keypad to it for ~30 minutes for a firmware update.

So far, I haven’t found any indication that Smartthings can do a firmware update for a community device type, so the updates have to come from an Iris hub v2 for now.

There’s much more discussion of these keypads here:

1 Like

@mitchp… Thank you!

Update…I dont know why it flipped my pic…


My batteries died pretty quickly as well… I was thinking about buying rechargable ones. I found some at 3.7V the ones that came with the keypad are 3.0V… Can I use the 3.7V ones?



Generally for the price of a decent pair of rechargable lithium batteries and a charger, it’s actually just cheaper to go on ebay and find a Lowes Iris Hub v2 (Mine cost about $25, with free shipping), and do the firmware update that fixes the battery drain issues.

I’ve searched for this and coming up blank so hoping someone can help on this… I found what I thought was the Centralite Xfinity Keypad on ebay and purchased it. Trying to install it today and when pairing it wouldn’t identify it as Centralite, only as “thing”. I went in to IDE and change the device handler to Centralite. Shows unarmed, temp, and sees motion sensing. Network light lit and green status light but won’t allow me to arm/disarm etc. I tried repairing several times with same result. Started looking more closely and it appears the unit I bought is made by Universal Electronics, not Centralite. A newer version perhaps? Anyone run in to this and is it possible to get it working with this device handler or am I SOL? Any help appreciated!

I understand your frustation. Keypads are supported by the Community, there is no official Smarthings support for a keypad.

Use the DTH at miriad/Centralite-Keypad/master, or you may get it at this link: https://raw.githubusercontent.com/miriad/Centralite-Keypad/master/devicetypes/mitchpond/centralite-keypad.src/centralite-keypad.groovy

Along with these two SmartApps

  1. Lock Manager (includes keypad support)
  2. Smarthome Exit and Entry Delay

Hopefully should get you up and running. I’m using this exact setup with an Xfinity/Centralite Keypad.


@mitchp I was going around the house calibrating my devices for temperature. When I got to the keypad I found that the temperature offset didn’t have a “Minus” offset, only a “Plus” for temperature. I believe I have the latest code from Github. What am I missing? The section of the code I am referring to is this below.
private getTemperature(value) {
def celcius = Integer.parseInt(value, 16).shortValue() / 100
if(getTemperatureScale() == “C”){
return celcius
} else {
return celsiusToFahrenheit(celcius) as Integer

private Map getTemperatureResult(value) {
log.debug 'TEMP’
def linkText = getLinkText(device)
if (tempOffset) {
def offset = tempOffset as int
def v = value as int
value = v + offset
def descriptionText = "${linkText} was ${value}°${temperatureScale}"
return [
name: ‘temperature’,
value: value,
descriptionText: descriptionText

Try -n. Tested with -5 and it worked for me, but had to tap the reset icon a few times for it to show.

I would, but the IOS keypad when it pops up for this has no - sign available. Normally in the code is a blue + or - option.