CentraLite Keypads

@zcorneli - I bought a new IRIS Keypad today and it behaves exactly as the old one did. The antenna light in the top right will do a double blink every couple seconds while the app continues to search for the device and not find it. Any other suggestions?

@Neight: As far as I can tell, That double-blink indicates the keypad is in pairing mode, and if the smartthings app isn’t finding it, there’s something wrong between the keypad, the smartthings hub, or the app.

Even without the DTH, or any of the software here, it should pair as a “Thing”, and go into the fast-blinking network light mode, so it shouldn’t be anything with the software.

I’d contact SmartThings support at this point, given that you have 2 different physical devices that both fail to pair in the same way. They may know something (An issue with a recent firmware update, or similar) I don’t.

The only other “diagnostic” thing I could suggest is uninstall the DTH, and try pairing again, but I suspect that’ll result in the same things.

Since @agh1701 is reporting the same issue, I would imagine this might be the result of a firmware update for the hubs causing an issue.


I have an e-mail into customer support. I will post the response when I get it.

I just bought the keypad yesterday. I used the most recent DH, Smart Alarm app, and User Lock app that I could fine on this thread (wasn’t easy lol). So far everything works perfectly. I ran through a bunch of routines and “scenarios” this morning and everything worked as I had hoped. The keypad runs the appropriate routines when the codes are entered; the keypad beeps for the exit delay and for the entry delay that I have set in the Smart Alarm app; the LED on the keypad changes color when appropiate; and the keypad LED and delay beeps respond to manual routines run from my phone.

The only issues I ran into where when I had an older DH and SA installed, after adding the most current ones it works flawlessly (so far).

Thanks everyone for their help doing this. I’ve needed something to make ST alarm operate more like a standard alarm to accommodate everyone in the house.

My response from Smartthings Customer Support

Thanks for contacting SmartThings support! I’ll be happy to help you.
I’m sorry to hear about the trouble with your keypad. While I can offer some general tips for helping your hub recognize the keypad, because the keypad is not an officially supported device it may unfortunately not work properly with SmartThings. In that case, the community would be the best suggestion I have for finding support for that device. With that said, there haven’t been any recent changes that should prevent this device from connecting, but it’s possible that it may not work properly even if you can get it connected.
If your other ZigBee devices are working ok, we can be sure that the hub’s ZigBee radio is working properly and can rule that out as a possible cause. You can verify this by removing and re-pairing a different ZigBee device; if you have trouble there, or if your other ZigBee devices aren’t working properly, please let me know and I’ll be happy to look into what’s happening there.
Most often when you have trouble pairing ZigBee devices, it’s due to range or interference. Be sure you’re bringing the keypad as close as possible to the hub during pairing, and be sure that you’re performing the proper reset/pairing procedure for the keypad. You should be able to find this in the user manual for the device.
To reduce sources of interference, power off any nearby Wifi devices, and ensure the hub is at least a foot or two away from your wireless router. Other electronics can also interfere with ZigBee devices; anything on the 2.4 GHz spectrum may have an effect here. Please see this article for other possible sources of interference and ways to combat them:
A guide to wireless range and repeaters
Finally, double check that the device hasn’t accidentally paired in the background. It’s possible on occasion for a device to pair with your hub but not show a confirmation during the pairing process. In the SmartThings app, tap My Home > Things and look for your device listed here. Additionally, please note that because this is a ZigBee device, Z-Wave repairs will not affect how it connects to your hub.
While I can tell you that our teams are working to officially support some form of keypad, I’m sorry to say that there aren’t any that we do support at the moment. For future reference, please be sure to check our compatible devices list to ensure that the device you’d like to use with SmartThings is compatible and supported.
If you have any other questions or if there’s anything else I can help with, please let me know! We’re always here to help, and you can reach us any time by email, via live chat on our support page if you prefer, or via 1-800 SAMSUNG, Monday through Friday from 9am-6pm PST.
Best Regards,

@zcorneli - So I unplugged my hub and let it sit for a day without power or batteries. I installed the DTH from the link in 752 then reconnected the hub and kept it several feet away from my other devices. I put the keypad in pair mode and after about 2 mins. it recognized it!!! I then installed and setup ULM and SA separately. Now the keypad is cycling the bottom three lights. Im not sure what I did wrong but at least my hub is recognizing it now.

Use the DTH from post 906 (or thereabouts), it has a few fixes specifically
relating to this issue. You’ll need to re start the whole pairing process

When you go to pair it, once smartthings recognizes it the network light
should move to a rapid flash. After it’s in the rapid flash mode, tap the
tamper switch once. After some time (up to about 10 minutes apparently),
it’ll beep, and finish the pairing process, and the network light will go
solid. After that, configure ULM and SA, and everything should work again.


I tried turning off 2.4GHZ on my router and then paring. Still no joy.


It looks like @Neight’s solution was to have the hub off (with no batteries in it) for 24 hours, then attempt to pair (Potentially waiting a bit). Can you try this?



Will have to try this on the weekend. Thanks.

So, have a few updates:

Some updates to the DTH code (Much of this based on @RudiP’s code improvements):

  • Better tiles! (Much nicer view in the app)
  • Better support for Beep (and the Tone capability)
  • Support for reporting panic as a contact and the button (Some applications only accept contact as a device)
  • Support for reporting motion events when the keypad wakes.

Updates for SmartAlarm:

  • Chime support! (Add your keypads to the “Chime Devices” list in the “Notifications” page to get chimes to work)
  • Support for enabling or disabling chimes for specific zones. Contacts are on by default, others are off by default.

Also, I’ve confirmed that while using User Lock Manager, 2 keypads works flawlessly. This is also true with SmartAlarm (Control, status, and chimes)

Links are same as primary links previously, but provided for convenience now.

DTH (Same link as before):

ULM (Same link as before):

Smart-Alarm (Same link as before):



Nice job Zack. I’m glad you’ve found some use for my updates to the original DH. Thanks to Mitch (@mitchp) for creating this device :wink:
I have 3 Iris Keypads and made the changes to my needs, like most of my devices. I’ve started to publish the code to GitHub but then I got busy and never had the chance to publish the changes here in the forum. I’m also glad that you guys found it.
Cheers :sunglasses:

I can not find chime devices in the notifications page…i do see it under zones

Sorry about that, I was dumb and didn’t actually push to github. Should be present now.

As a note, You’ll probably want to go into the preferences on the keypad, and change the default beep length to 1 (A single beep), otherwise the “chime” will actually be 3 beeps by default.



If you’ve got other changes pending that you think would be useful, feel free to either submit a pull request to my repo, or just post the code somewhere and point me to it. I’d like to make this DTH as versatile as I can.


Thanks for putting in the work Zack. It might be worth creating a new post so that you can have better visibility for your code. I would suggest something like “(RELEASE) Centralite 3400-X Keypad and Lowes Iris Keypad DeviceType”. This would allow users to find all of the most up-to-date code and information easily.

1 Like

So the DTH in 906 did not work for me, but when I went to post in the forum last night, I noticed some updated DTH and Apps. I installed the newest DTH after letting my hub sit overnight, I was able to get the keypad to pair this morning as I left for work. I added the new smart apps at work and am excited to see if the keypad is working when I get home.


I’m moving this to a new topic, here:

This should make it easier to keep track of which versions are newest, and move this into a shorter thread for new users to see what’s going on, and easier to announce new features

1 Like

Hello Guys,

Thanks for this great work! I have one question.
If I only enter the code at keypad it jumped to armed home.
If I press the middle "walking (away) button and enter the code it jumped to armed away after 30sec.

So but HOW I can disarm the keypad and showing them green LEDs
I’m using the stock Centralight 3400 Keypad with the buttons A and B and not off and on.
For setup I used the user lock manager smart app.

It would be great if you can help :slight_smile:

Hi all,

I’m having a problem re: pairing the Iris keypad. I’ve used the advice: here and added the IDE & SmartApp.

Firstly, it says go to IDE - My Devices - Find Thing. Find Thing doesn’t appear, but there is an option to add an item. It asks for a Device Network ID - how do I find this? EDIT: I’ve found it somehow because it’s partially added, so now I have the item half added to the Android app but it won’t configure because I assume there’s no Smartapp installed even though I’ve done exactly that and the Device Handler? The above article says go the Marketplace in the Android app and the smartapp will be there, but they’ve changed the layout of the app recently and I can’t find it? I can see some custom apps people have made but not the one I’ve just added.

It also asked for the item to be added to either a Hub or Location. Both drop down lists are blank. I’ve tried to add a hub but it tells me ‘use your mobile app to add a hub’, which is strange as it’s right here and controls many devices fine. I added ‘Home1’ and I could add the device there, but I think that might confuse things?

Further edit, I have got a bit further. The Smartapp wasn’t saving for some reason and now it appears under a new section called MyApps in the Android app. Now it won’t allow me to add the keypad because I can’t actually select it in the config screen (see the first field ‘You can’t currently add this’ in the screenshot below)

Any advice would be appreciated as I’m really having a hard time getting this stuff to work