Can't turn on "Get your location from this phone"

I am trying to enable the location service using my iPhone. When I click on the slider to turn on the “Get your location from this phone”, it turns on, then immediately turns back off. It doesn’t display any error message. I have checked the location permissions (set to “always”). I have reproduced this problem with multiple iPhones and an iPad. I have tried rebooting (both phone and hub) and removing the app and reinstalling. Any ideas?

  • are using the main ST account or shared account (if Shared - were permissions set)
  • how many locations do you have?
  • have you set up Geolocation for the hub in the ST app?
  • iOS app version?
  • iPhone OS version?

I believe I remember another user reporting the same issue a couple of months ago but don’t believe it was reported as being resolved.

  • It’s the main account.
  • I think this started after I tried to add another location. I’ve since deleted the second location and now only have a single location.
  • iOS: SmartThings Version
  • iPhone: iOS 16.5

I tried searching, but I didn’t see anything. I texted Samsung tech support, they suggested a factory reset. I really don’t want to do that.

use API Browser+ or legacy IDE to check if there is a device for your phone in the Device list. If you have multiple iPhones in your household, it might get trickier since they should all be labelled iPhone. If you find yours, remove it. Then force quit the ST app and try to enable Get Location. Now sure if that will work.

report the issue to ST support again if you continue having the same problem. I suspect it may have to do with the second location you deleted. I would suggest not resetting your hub… call them back and ask that the ticket be bumped up to higher level of tech support.

I’ve checked both the old IDE and the API Browser+; no listing for iPhone(s). Thanks for the suggestions.

Same problem. I’ve had two locations for years. Suddenly stopped seeing presence. Cannot turn the toggle on. I’ve re-installed the app, re-booted, etc.
Simply cannot make it work!

They suggested a factory reset of what? I’m at the end of my troubleshooting abilities here. Same problem (same version and iOS numbers), but I’ve had my second location working for years! Suddenly stopped working today.
API Browser+ shows only the other phone that shares this location. Can’t figure out how to add my phone back in! (How did you get a way to txt Samsung???)

I am having the same issue.
I turn on get location from this phone and it immediately turns off.
I also have two locations, two houses, two hubs.
I uninstalled and reinstalled. — NOPE
I Installed on a different device. — SAME ISSUE. This tells me the issue is with the ST app or ST backend.
One hub/location has 6 members and only my account is failing.
I reported it a few days ago. I call them daily. Hmmm.

They told me to perform a factory reset of the hub. I don’t want to lose all my devices, so I don’t plan to try that. I suspect it wouldn’t help anyway.

I don’t recall where I found the text option. It was a general address for Samsung, it was slow and not helpful. I wouldn’t suggest the text method.

Well… I submitted an error report and they have asked me for additional information (screen recording showing the problem and error logs from my app), so it appears that they are actually working on this. (I hope so!)
It may or may not help, but if you want to report the problem to them, you might want to reference the existing error report -
Re: 1500706 | Cannot turn on “Get your location from this phone”

(You can send problem reports to

I’m having the same problem on my Pixel 6. Presence wasn’t working so I turned it off to try to turn it back on and now I can’t turn it back on.

Oddly, it seems to work fine now. Apparently they fixed it (at least for me).

Mine is fixed as well. And I just sent a note to support earlier today.