“Get your location from this phone” Not turning on with new phone

I just upgraded my phone from a Samsung S21 Ultra, to the S23 Ultra. All migrations (even Smartthings) went fine, however when I try to enable “Get your location from this phone", I get an error at the bottom saying “There was a problem connecting. Try again later”. I have contacted support, and went through the normal troubleshooting procedures (uninstall/reinstall, sent app logs, etc etc). I even downloaded an older version of Smartthings as I read that fixed other people’s problem, however mine still persists. I also logged into the IDE and verified the old phone was gone.

Any thoughts? Right now NONE of my presence based automations are working. As a side note, I also tried to re-enable this on my old phone, and now getting the same error there

Best thing you can do is report it to ST support:

That’s the exact error I get

My wife just got this exact same issue trying to upgrade from S20 to S23. Just sent a message to support.

All good now, at least on my end. I guess they did something on the backend? Either way, mine is fixed, at least for now