Can't specify another account to use with SmartThings app?


(John Cassidento) #1

Hello,

I recently purchased a SmartThings hub, and I want to be able to use the SmartThings Android app to control connected things with my Samsung S7 Edge. However, the app is forcing me to use the gmail email address that is associated with my Samsung S7 Edge, and does not let me use another account I would like to set up specifically for this SmartThings hub.

The gmail email address is the address I use when I log into the Play Store to install apps, for example. Running the SmartThings app, regardless whether I choose “New to SmartThings” or “ I’m a SmartThings User”, it keeps referring to my “Samsung account” and saying :
xxxxxxxxxx@gmail.com
You’re already signed in to this device with your Samsung account. Tap Continue to proceed with this account or go to your phone settings to switch accounts.

I tried using a PC to create a new Samsung account associated with a Verizon email address, and I can log in to the Samsung site with this information. However, I cannot point the SmartThings Android app to use this account instead of the gmail account.

I can go to Settings > Personal > Accounts to see the list of accounts on this phone like for Email, Facebook, Google, Exchange, and Samsung, and some of these use my Verizon email address. I see that it has identified the gmail address for my “Samsung account”. However, I cannot add another email address to my “Samsung account”. If I attempt to Add Account, I see SmartThings as an option, but if I click on it, it beings me back to the SmartThings app and I have the same problem as above.

So, my only option at this point would seems to be to remove the email address associated with the Samsung account and add the Verizon account in it’s place. However, if I choose Remove Account, it says :

 Removing the account will deleted all of its messages, contacts, and other data from the phone.  Continue ?

It does not sound like I want to do that, since I have installed all of my apps on the phone from the Google Play Store using the gmail address.

** So, is there a way to associate the SmartThings app with another SmartThings account, other than the one associated with my Samsung phone ?

P.S. I would like my kids to be able to control lights, etc. with their iPhones, and I have no idea how that would work if I can’t even get the Samsung ST hub and app to work with my Samsung phone. Thanks,

- john

(Jimmy) #2

Have you emailed support? Support@smartthings.com or do you have any iOS devices to try?


(Moh) #3

Hello All
Sorry to hijack this thread but I’m suffering the same issue with the OP.

I recently upgraded my phone and had no problem logging in to my smartthings mobile account.

Now on my new phone (Samsung Note 8), I have a message saying if I want to use my current Samsung account (which I do not).
The screen doesn’t progress and ask me to sign in to my Samsung account as before.

If there a fix to this??

I’ve read that Samsung Connect may be causing this issue.
My old phone didn’t have this software bit the new phone does


#4

Try going to Settings / Apps and open SmartThings and Clear Cache and Delete Data and then Force Stop app. If that doesn’t work, do everything again and uninstall app and then reinstall.


(Moh) #5

Hi @WB70
I have tried that but still no dice.
ST Mobile still wants to insists I log in with the Samsung account on my phone.

I wish this apparently was more like the Amazon Alexa.
When you require an account linking, a browser opens within the app, asks you to log in then returns back to the Alexa app, simple.


#6

When you enter your email address, you are automatically directed to the Samsung account login. If you goto the web and login to https://account.smartthings.com, the same thing occurs. My original account was an ST account but you are still directed to the Samsung account

First page:

After hitting next, I am presented with Samsung account with the email populated in yellow (hidden from screenshot)

Then I enter password and Next and it logs me into my IDE. The ST mobile app works in the same way.


(Moh) #7

@WB70
That’s how my old phone used to log in.
Now I don’t get that option.

Do you have the Samsung Connect apparently on your phone (this thing came preinstalled in my phone already)


#8

I manually installed it on my phone to see what it had to offer. The one thing I couldn’t stand about it, was that it always tries to autologin and I get pop ups on the screen trying to reconnect even though I force closed the app. So I uninstalled it from my phone. No need to have that app right now as it is very limited in what it can do.


(Moh) #9

@WB70
Many thanks for trying to help.
I’ve just uninstalled Samsung Connect (didn’t think I could as it was preinstalled but strangely enough the phone let me) and I still coundnt log in.

Something is still causing my default Samsung account to load up and I can’t enter my details.

Any other ideas??


(John Cassidento) #10

Just got feedback from ST support :

I am sorry to hear that you are having account troubles. You are definitely on the right track, but we really only have 2 options to resolve this issue. The first, would be to sign out of the Samsung account on your mobile phone. This would give you the ability to choose what Samsung account you would like to sign into. However, this process will delete anything you have saved under your Samsung account currently.

The second option, which in my opinion is the better of the two, would be to create a SmartThings only account to sign into the SmartThings mobile application. This can be done by using this link (https://graph-na04-useast2.api.smartthings.com/) and clicking on register now. Once you have created the SmartThings only account, you can then sign into the SmartThings mobile application by selecting “I’m a SmartThings User”.

I hope this information helps to resolve this issue at this time, but in the future we are migrating to Samsung accounts only, which may cause you to have to use option one to sign into a different account.

This actually seems to have worked for me. I guess I had created a Samsung.com account and not a SmartThings specific account. I even used the same email address for my SmartThings account as my previously created Samsung account. Now, when I run the app, it does not give me the warning about my Samsung account. Instead, after I enter my email address, it asks me to select whether I want to use my Samsung account or my SmartThings account. If I choose SmartThings, I finally get to the screen where I can enter the code on the hub. I think I am up and running.

restricting it in the future so one has to use the Samsung account is not what I want to do because my phone is through work and this is a personal project. I suppose if I had a separate personal phone I would do this, but I don’t. So, looks like it is Wink hub or Hue hub for me. This is just asinine.


(Moh) #11

@JohnnyCass
Why can’t they change the mobile app and let users choose which account they want to log on to??

This is so frustrating.

So it looks like those who upgrade their phones in future are screwed.

I personally have several android devices with several Samsung ID.
I expect to use 1 ID to log in to my smartthing device.
The only alternative is to create multiple users so that I can log in to my smartthings (don’t really want to go down that route)

I too have opened a support ticket and shall definitely be complaining about this issue.


#12

IMPORTANT!

This is incorrect. Please don’t tell people to login using that link. There are many many shards that exist and not everyone belongs to the na04-useast2 shard. This will cause even more confusion for people out here that already have issues. :slight_smile: FYI, if you goto that link, and select login and then create new account, it redirects you to the Samsung account creation page, not SmartThings.

For existing users, you use https://account.smartthings.com and then when you successfully login it redirects you to your correct shard.

For creating a ST specific account, I would recommend that you use this instead:

https://graph.api.smartthings.com/register/index


(Moh) #13

Hi Guys
I think I’ve found a temporary Solution, please see here:


#14

WB70, this worked for me. Thanks!