Can't set custom notification sound (Android Oreo)


(davedogcaddy) #1

I just replaced my dying Samsung Galaxy S6 with a shiny new S9 which runs Android Oreo. While I’ve set the notification sound in the SmartThings (Classic) app to the sound I prefer, it continues use the notification sound that the phone uses for everything else (the default one). Any ideas? Thanks in advance!


(William Lanoue) #2

I have the same issue on my S9… Since default is a single beep it is not much of a help. You would think Samsung would have got this right given Smartthings is theirs.


(davedogcaddy) #3

Finally figured this out! Looks like Android Oreo handles notifications differently, although other apps (Like Facebook for example) don’t seem to have a problem pushing their own sounds, so I think the SmartThings app needs an update. For now, here’s is how to fix it:

  1. Open the Android Settings app
  2. Select Notifications
  3. Scroll down until you find SmartThings and click on the word SmartThings (not the toggle button)
  4. Click on the word Notifications (not the toggle button)
  5. Click on Sound, and then select the notification sound of your choice.

That’s it!