Can't Remove Device

I have a problem with the ADT / SmartThings Hub. I was trying to pair a new motion sensor and it just got stuck during the process. I tried several different time but to no avail.

However… this is where it gets weird,

The device does not show in the App, Online at The Groovy Website, or anywhere else, except on the actual hub if I go to bypass devices it is listed there. It will also trigger the alarm. I would like to remove the device all together but do not want to reset the hub as I have a ton of devices around the house and custom automations running.

Thanks for any help

at ?

what is the brand/model of the motion sensor?

ADT motion sensor

Have you contacted ADT or ST support?

Contacted ST support and they escalated my case, but won’t hear back until next Tuesday to Wednesday

Here is the help page for that device:

Did you try resetting the device and connecting again?

Yes several times.

I have had this issue over and over again. In fact I just tried to remove and re-add two ADT motion sensors and they are stuck on the hub but don’t show up on the app. This is an ongoing problem. I will have to make a call to support and have them force remove them off the hub, only to have them stop working in a few months. Very disappointed with this issue.