Can't Integrate Netatmo Weather Station and SmartThings


(Mark) #1

I may be missing something obvious but I’m unable to get my Netatmo weather station to work with SmartThings. I copied the code I found on GitHub and published it, and I see the app in My Apps. When I try to open it, I see the spinning “wait wheel” very briefly, it disappears and then nothing else happens. If I use the simulator and review the log, I see this:

error java.lang.RuntimeException: Unexpected status code 400 from global /clients/null with status text @ line 56

Line 56 is the last line is the following block:

if (!state.accessToken) {
	log.debug "About to create access token."
	state.accessToken = createAccessToken()

I’m not sure if I’m using the wrong version of the Smart App, if the code no longer works, or if it’s operator error on my part. Or maybe something else completely. Any help is greatly appreciated.


#2

I’m not sure what code you found, but I would start with the quick browse list in the community – created wiki and look under smart apps on the “weather” list.

There’s one there for the Netatmo which is quite popular and seems to be up-to-date. :sunglasses: It has both the DTH and a smartapp, so you can look on either list.
You can ask any further questions in the author thread.

http://thingsthataresmart.wiki/index.php?title=How_to_Quick_Browse_the_Community-Created_SmartApps_Forum_Section#Quick_Browse_Links_for_SmartApps


(Rudi Prunzel) #3

The official SmartThings integration with Netatmo has not been working for almost a year now.
Look at the following alternative (this is working fine for me in the US):


(Mark) #4

Rudi, thanks for the reply. I published the code available at the link you provided but still just get the momentary spinning wheel and then I’m right back at the SmartApps screen. I suspect I’m not doing something correctly. Is there any documentation I can look at so I can figure out what I’m doing wrong? Thanks!


#5

I followed the instructions linked above this morning and I can confirm that it worked for me.


(Mark) #6

Not sure what I’m doing wrong but after creating the DTHs (basestation and module) and installing the app, the only device shown when I open the app and select Select Device(s) is Netatmo Module. If I select that, the outdoor module (only) appears in ST. Can someone help me understand how I also get the basestation to show?

Also, when I look at the DTH for the outdoor module, I see this: capability “Carbon Dioxide Measurement”. But I don’t see that value displayed when I look at the outdoor module in ST. I’ve include a screenshot below.

To summarize:

How can I get the basestation to appear as a thing in ST?
How can I see the carbon monoxide reading for the outdoor module?

As a note, I’m not sure if it makes any difference but I’m using a V1 hub. I’ve deleted everything and started over 3 times but still no love. And apologies for the duplicate post. I initially posted this to the wrong category.

Thanks for any help anyone can provide.

Update: I went into the IDE and manually created a device using the basestation DH. I can now see the basestation in ST but all values are blank and I see this in the log when I hit the refresh icon:

6ab9125e-f847-43d4-b118-d4e41b26c8c3 10:54:56 AM: error java.lang.NullPointerException: Cannot invoke method poll() on null object @ line 140
6ab9125e-f847-43d4-b118-d4e41b26c8c3 10:54:56 AM: debug Refreshing