Can't get new hub to connect, just solid blue LED, then brief solid magenta, then off, then back to solid blue

hubv2

(Damian Edwards) #1

Just bought a new SmartThings hub but I can’t get it through initial set up. It sits on solid blue LED for a few minutes before changing to solid magenta LED for a few seconds at which point LED goes off completely, followed by the cycle starting again a few seconds later.

I’ve tried connecting it via my router (Netgear R6700) and directly to the ISP provided hub (I have fiber direct to the house, so the hub is directly on the ISP network). FWIW I’ve worked in IT for >20 years and know my way around networking.

When it’s on my router, I can see it on the connected devices screen and it has an IP address.

I’ve tried the reset button and removing the batteries for a few minutes. It just refuses to connect.

Any ideas?


(Bernie H) #2

Have you setup the hub through the smartapp and a location? Does the app see the hub?


(Damian Edwards) #3

The app never got past the hub initialization stage, i.e. it never found it and asked for a location.

The blue LED stays on for exactly 90 seconds before going magenta for a few seconds then off. Seems it’s hitting a timeout of sorts before starting again.


(Bernie H) #4

Check this out for the LED color meanings
Looks like it’s trying to update


(Damian Edwards) #5

Yeah, but it just does it in a loop, over and over. If it’s indeed trying to update itself, appears it’s failing.


(Bernie H) #6

You should setup all the location stuff then the hub I believe

IDK but see if this helps at all https://support.smartthings.com/hc/en-us/articles/205380634 Link corrected


(Damian Edwards) #7

Thanks, I’ve been through all the guides numerous times though. I’ll leave it plugged in overnight and see how it goes.


#8

Have any luck? Same thing here.


(Damian Edwards) #9

I got a replacement hub and it worked fine.