Can't delete My SmartApps or re-enable GitHub Integration

Let me start by saying I’m a total newbie and having been experimenting more than I should. And, I apologize if this is the wrong forum.

Here’s what I did. I had GitHub Integration working and had added the Rule Machine. When I was trying to update RM I ended up adding a boatload/500+ SmartApps including duplicates. So now when I look under My SmartApps there are over 500 entries and new one’s keep appearing. I’ve tried the pain staking process of deleting them one by one, but they never seem to go away. I’ve also tried deleting them in My Apps using the Marketplace on the iPhone app, but they don’t delete.

The Enable GitHub Integration button is showing up under the My SmartApps section but it just brings up the message Using these tools you can manage your hubs and devices, give them unique names, and organize them into locations and groups.

I’m trying to remove the 500+ My SmartApps and re-enable GitHub. I’m willing to delete whatever I need to get this fixed.

Thanks in advance!

Try these instructions:


If it works for you, you’ll be able to remove them in fairly short order.

Thank you, but unfortunately that doesn’t remove the apps under the My SmartApps section.

You can’t remove those until you remove the configured instances.

I don’t know what you mean by configured instances. How do I remove the configured instances?

GitHub integration is broken. I have the same problem and contacted support regarding it. This is what they sent me:

Auston (SmartThings)
Jan 19, 2:46 AM

Hey Willie,

This looks like a known issue and other customers are experiencing problems with it. We are aware of the bug and are working on a resolution, but at this time there isn't a definite timeline for when we can have a fix in place.

I'll be keeping an eye on this issue and we'll let you know when we expect to see it resolved.

Thanks so much for working with us.

Auston
SmartThings Support
support@smartthings.com
Help me help you!

Thanks wve. That’s a rather disappointing response. One that you don’t see too often from a vendor or reseller.

The GitHub integration aside - I would still like to remove all the apps installed under the My SmartApps section, if anyone has any ideas or can tell me how to remove the configured instances.

Follow the directions I provided earlier. If successful, you should then be able to delete them from My SmartApps (using the Edit Properties button).

Bob, just to make sure. Below is a screen shot of the apps that I can uninstall - which I’m willing to do. However, I want to make sure that I’m clear that the apps I really want to remove are the ones under My SmartApps in the next screenshot. Are you saying that if I uninstall these apps then I’ll be able to remove the apps in the bigger list below?

This is a screen shot of the apps I’m trying to remove - there are over 500 in the list. They are under the My SmartApps section in IDE.

We had a communications problem. When you have a configured instance of an app, it will appear indented from the main SmartApp (as in the “Turn on WeMo” in your first screenshot). I had interpreted your first post to mean that you had created duplicates of configured SmartApps. If the ones you are trying to delete in the second screen do not appear in the first screen, then there is nothing for you to do in that first screen. Sorry for the confusion!

Now, if you’re saying that you can’t delete them from the second (i.e., My SmartApps) screen (and I think that’s the case), then I’m afraid the only alternative is to contact Support. I’m sure someone will chime in if there’s an alternative I’ve overlooked.

Yeah, I figured that I wasn’t explaining it clearly. Thanks again for trying to help.

Yes, I’m trying to delete them from the second screen shot.
I sent a ticket to support a couple of days ago, no response yet.
Like you said, maybe someone else will see this and have a suggestion.

wait, so github integration is broken if we’ve deleted it? i have the same problem now :frowning: