How do I delete extra GitHub listings in the IDE


(Allan) #1

I had some GitHub integrations where the author is no longer producing code or its bene upgraded to something better. I tried to delete some of these but the system won’t let me leave them blank so I copied the last entry a couple times to overwrite the dead repositories. It seems only option is to do that or put in junk information and have it give me a error that the GitHub repo can’t be found.

How do you delete the extras?

On the same token say the dead repo is second in the list. If you move the entries up, overwriting the second one with the third, third with the fourth, etc, it messes up your apps and handlers. If you go into one of them it still lists the repo that was in “position” 2 but not the right name. Why doesn’t that update? For example if you have three repos listed and you have device handlers tied to one and three if you move the repo from position three to position two the device handler can no longer update…you have to either leave a dead repo or update the device handler. Why?


(Allan) #2

So apparently you need to log out and log back in and then you get a delete option next to all of the duplicates except for one. Unfortunately the delete buttons are random:

So I clicked in and out of “Settings” enough times to make the bottom two have the delete button and then deleted them. Still doesn’t help the fact moving things will break the integration with your devices…anyone else that can verify this?


(Scott Shell) #3

The Delete button will only show up if your code is not linked to a repository.

if you click on the little icon on a smartapp that looks like a pen and paper.

It will take you to a page with a number of things on it… you are looking for the Source Code Options tab.

you can click on that little box and change it to none.

save the page and you should now be able to delete the particular repository.


(Allan) #4

Well thats not true…look at my example. I have a device linked to that last repository and all three are identical. Hitting Settings shows random delete buttons just like in the picture.

And that also doesn’t fix the problem of reordering the repositories.


(Ben W) #5

Try renaming them to another repo or branch, then you will see what ones are tied to SmartApps or DH. There are tones of actual ST repos you can use as temp fill.

Ordering is fixed via Repo Name/Branch.

You may have a database dependency screwing up removing them. Reach out to support and they should be able to fix you up.


(Allan) #6

No, no dependencies. I can in fact delete them…that’s not the problem anymore. The problem is as you can see from the images the randomness of the delete buttons. Not only that but when I tried to reorder my repo list it was messing up the devices that account for it. For example the 2nd and 4th repo in my list were both dead, when I moved number three into the second position and number five into the third position and saved it the devices in my list did not update. I had to manually go into each one’s definition and change the GitHub repository associated with them. Maybe it was just a fluke, because it seems right now if I reorder the list repositories stick with the right names. But before they were not.


(Ben W) #7

The randomness is most likely cased by the duplicate naming. The UI loads alphabetically and just happens to switch them around.

I am not sure what you mean in reordering, moving something up by replacing the repo name on next reload will reorder alphabetically.


(Allan) #8

The UI doesn’t seem to load mine alphabetically unless it considers upper case to be before lower.

As for reordering here is what I mean. My repo list right now is this:

I If I go into your device for example it looks like this:

I go back and click “Settings”. I swap the last two repos, moving yours up one and the other down. I click save:

I go back into your device. Look at the repo name:

It kept the name of the one in position 4 but not the name of the repo. If you follow the exact same steps (verify repo on device, swap repo with another, save, reverify device) are you saying you get a different result and yours works as expected? Or are you saying it fixes itself? Do you at least see what I see when you follow those steps?

-Allan


(Ben W) #9

Capital letters come before lower case letters. So your initial sort is alphabetically.

The results you are describing are correct. This is helpful if I stopped supported Enhanced Dimmer switch and some one else picked up the work. Then all you have to do is remove my Repo name and replace it with the new one and everything lines up.


(Allan) #10

sigh I don’t think you understand what the problem is. If I had 20 repos in my list attached to 20 different devices and I reorder the repo list it will mess up the linked repo on all the devices if you go into them and look at them. I understand the drop down on the devices list to select a different repo. That’s not the issue. The issue seems to be when you go into your settings and hit save it doesn’t refresh the page correctly so if you then go into any of your devices it appears they are linked to the wrong repo. If you follow the steps outlined a ove exactly you will see what I mean, reordering the repo list appears to mess up the link repo on the devices. But in actuality if you close your browser and go back in it does update correctly on the backside. It appears to be a display issue with refreshing of the page after changing the repo settings.


(Ben W) #11

I don’t think you understand the problem. You cannot re-order repos.

What you are doing is replacing the existing repo with a new one.


(Allan) #12

Ok, well that makes slightly more sense. The problem was I wasn’t getting delete options so I tried to reorder it and put all the “bad” ones at the bottom. Then all the sudden I was getting the option. I would think they would tie the devices to the name and not the order, especially since it reorders alphabetically but that’s not how the list works.


(Ben W) #13

Its not the order per say. I think they way the do it is good. I jump between my repo and the master repo when working on nest-manager. Its nice to just be able to rename the existing repository and have the 4 device handlers and the smartApp now point at the new one.

In databases names are not unique its the position or row id that is tied to the device handler/smartApp. How many repositories are named SmartThingsPublic? I have at least 2 or 3 in my list right now.


(Phil) #14

Old thread I know… but I haven’t found a solution:

Any way to differentiate between repositories with the same name (i.e. SmartThingsPublic)? When I’m in the IDE and go “update from repo”, I have multiple SmartThingsPublic ones and it’s always a guessing game.


(Allan) #15

As the original OP of this thread I can say no, there doesn’t appear to be. I just had this happen to me a week ago adding a repo that was named the same and then not seeing updates since it didn’t seem to matter which I clicked on as it always tried to pull from the top one of the two identical listed ones.


(Phil) #16

I was afraid that was the case… Thanks for the help. :slight_smile: