Can't connect zigbee on/off switch

hello, guys. I tried to do some research and couldn’t find any solution. so forget me beforehand for asking probably the most stupid question you ever heard.i’m new to ST.
so, I just bought v3 hub and added some Samsung sensors. everything is fine and working.
then I bought this switch:

now there are a few problems:

  1. when trying to pair the switch through ST classic- it’s recognised in auto search mode as ,THING’ and I can’t add it to any automation.i can add only my smart tv as a device to work with. the switch is not showing there. when clicking on THING switch- it said: please wait
  2. when I use ST app- it cant find the device at all in auto mode but can pair it if I choose manual mode-sensors-switchers and dimmers- any name there. any way afterwards ST said: cannot connect to device despite its connected. the switch itself shows me that its reacting to pairing process
    I heard something about Device Handler but have no idea what to do there. this switch is visible there.that’s what i see on that page:

    could you give me a piece of advice- what to do next. or may be advice me of any simple 220v switch that would definitely work with new v3 hub?


You’re on the right track.
Go back to the device page and click edit and you should see the drop down box to change the device handler.
In there you should have a ZigBee switch select that and save and then go back to your Smartthings app to see if it’s working if not go back and change it to another.
A default one should work but you may need a custom device handler for it I’m not sure as I don’t know that device.

1 Like

hi. thanks. wow!!! so simple? i cant beleive it. just yesterday i wanted to sell ST for half price. but not now!

1 Like

Guess that worked then :+1::laughing:
If you’re still selling though I’ll have them at half price lol

1 Like

hello. since no one replied to my post except you i just thought that you might be able to help me again.
this story still goes on. i bought another absolutely identical switches. and now they are not recognised by either application but still go through pairing process. the problem is: they dont show up in my devices list at all. how can i add them manually? i just thought that i can copy some parameters from my first switch that worked but i dont know some of them like zigbee id. thanks in advance and happy new year to all !!!

So it’s not showing as a new thing ?
You can’t just create a new device navigator as it needs a unique device ID that normally gets passed over when pairing.
There is a way to find the id manually.
Firstly create a new device identical to the working one and save, then on the SmartThings IDE website go onto the live logs and keep a eye on that.
Meanwhile start your device in paring mode and click on add things on the old app once started look at the live log and eventually you should see a line of text that says “catchall” at the beginning in there will be your device id you need to compare the working id to detect it.
So if the working one is 8 characters with numbers and letters etc that will be similar so then copy an paste that into the device id of the device you created.
Hope all that makes sense. :rofl:

thanks for your reply. this doesnt work. what i did so far:
disconnected working switch from mains and put not working one in pairing mode
nothing shows up in the log apart from that the hub cant find any device but the led on switch shows as connected. connected to what?
i cant create a new device identical to the working one. it gives error on smartthings ide
after hard reseting the hub i even cant add the switch that worked before. i deleted it from devices list before doing it
i deleted all devices, both apps from all phones. started everything from scratch. hard reseted the hub twice. still the same result. even working switch is lost. no matter what. tried installing, uninstalling apps. still can register samsung new sensors even on old app. but not the switches. something is wrong here
i dont know what was wrong. but after waiting a few hours after last update i tried to to connect any switch loosing any hope. amazingly they all have been recognized. so what was wrong?

@alexholins, I was just about to ask you try it again but it looks like you already have. We just rolled back a change we made a few days ago that unintentionally caused some problems joining certain devices.

thanks for letting me know. happy new year!!!

1 Like

Sorry about the late reply not been on here much with Christmas etc.
I normally get a mobile notification when someone replies but didn’t get anything :thinking:
Glad it’s working now anyway.