Can't add Hue Bridge

hue

#1

I’m having major technical difficulties when trying to add a hue bridge to SmartThings as a thing.

First problem is not being able to see the hue bridge while searching for new device’s. To get around this, I have to delete my home location and reactivate the smartthings hub. At this point, when searching for a new device I can see the hue bridge.

Unfortunately, when I click save to add the hue bridge, I get an error stating an unexpected error has occurred. When I try to add the hue bridge again, it goes back to not being able to find the bridge without deleting and reactivating the hub.
Anyone run into this issue? BTW, All the bulbs are working through the Hue app.

Error screens: https://imgur.com/a/8se6r
Hue bulb version: https://imgur.com/qEyiKrx

Smartthings Hub
Firmware Version 000.018.00022
Hardware Version hub v2, US customer Rev E

Hue Bridge
Hardware version v2.1
Firmware version 1709131391 (latest)

Any help would be greatly appreciated!


#2

Here is the log from the IDE when trying to add the hue bridge as a thing:

removed log


(jkp) #3

Did you try pressing the button on the hue bridge when attempting to add it to your ST hub?


#4

Yes, when I can actually get to a point when ST asks me to press the button, I press it.

FYI my ST zigbee channel is 14, and Hue Hub channel is 15.


(jkp) #5

power off the hue bridge, reboot your ST hub (in ide under My Hubs: View Utilities: Reboot Hub) then power your hue bridge on and try to add. deleting your home location is not a good idea.


#6

ok, i won’t delete my home location. I followed your steps, and it brought me back to the same symptoms. I can see the Hue bridge, add it, then ST gives me an error. See screenshots here: https://imgur.com/a/1Vypv

Also, i captured the logs from IDE. Note the errors during linking process.

removed log


#7

Anyone have any suggestions?


(Jason) #8

Did you get in touch with SmartThings support?


(Fiver55) #9

I was having the same problem with the same logs so i bookmarked this thread. Tried a myriad of different steps.

Unrelated to the above, I had both my hue bridge and my smarthings hub powered down for about 24 hours while I was doing some maintenance. Everything started magically working when I powered them back up, the hue hub was found and added instantly.

Sorry that’'s not real helpful as I don’t know the root cause or if having them both down for so long was the actual fix or not. Worth a shot maybe powering them both down overnight and see what happens.


#10

Wow… it just randomly started working all of a sudden. I didn’t reboot anything! Very strange, but glad it all works now.


(Antony Pugh) #11

Had you added it in the past or at least on the same account

I removed mine a while back and when trying to readd it wouldn’t see it or if it saw it failed to connect.

Apparently there is quite a delay on it cleaning up on the hub and cloud before it can be readded. Mine worked fine 24 hours later.